Wenn

30/01/2008 - 11:29 von Marcus Friebe | Report spam
Hallo

In meiner Tabelle werden in der Spalten AI (Feste Feiertage ausgegeben)
mit der Funktion

=WENN(A2="";"";(ODER(UND(MONAT(A2)=1;TAG(A2)=1);UND(MONAT(A2)=5;TAG(A2)=1);UND(MONAT(A2);TAG(A2)=3);UND(MONAT(A2);TAG(A2)%);UND(MONAT(A2);TAG(A2)&))))

und in der Spalte AJ (bewegliche Feiertage) mit der Funktion

=WENN(A2="";"";ODER(DATUM(Jahr;MONAT(A2);TAG(A2))ÚTUM(Jahr;3;22)+Ostern-2;DATUM(Jahr;MONAT(A2);TAG(A2))ÚTUM($A$1;3;22)+Ostern+1;DATUM(Jahr;MONAT(A2);TAG(A2))ÚTUM(Jahr;3;22)+Ostern+39;DATUM(Jahr;MONAT(A2);TAG(A2))ÚTUM(Jahr;3;22)+Ostern+50))

Hier erhalte ich ja die Werte "WAHR" oder "FALSCH" zurück. Die "WAHR"
Werte werden gezàhlt mit hilfe von ZàhlenWenn.
Jetzt fàllt im Jahr 2008 der Tag der Arbeit & Christi Himmelfahrt auf
den selben Tag, nàmlich den ersten Mai. Wie làßt es sich am einfachsten
erreichen, das nur einmal "WAHR" gezàhlt wird?

Für Hilfen jeglicher Art bedanke ich mich schon einmal im Voraus.
Mit freundlichen Grüßen
Marcus Friebe
 

Lesen sie die antworten

#1 Peter Schleif
30/01/2008 - 16:54 | Warnen spam

=WENN(A2="";"";(ODER(UND(MONAT(A2)=1;TAG(A2)=1);UND(MONAT(A2)=5;TAG(A2)=1);UND(MONAT(A2);TAG(A2)=3);UND(MONAT(A2);TAG(A2)%);UND(MONAT(A2);TAG(A2)&))))

=WENN(A2="";"";ODER(DATUM(Jahr;MONAT(A2);TAG(A2))ÚTUM(Jahr;3;22)+Ostern-2;DATUM(Jahr;MONAT(A2);TAG(A2))ÚTUM($A$1;3;22)+Ostern+1;DATUM(Jahr;MONAT(A2);TAG(A2))ÚTUM(Jahr;3;22)+Ostern+39;DATUM(Jahr;MONAT(A2);TAG(A2))ÚTUM(Jahr;3;22)+Ostern+50))



Die erste Formel konnte ich zum Laufen bringen; bei der zweiten fehlen
mir die Variablen 'Jahr' und 'Ostern'. Dessen ungeachtet hast Du
mindestens zwei Optionen. Beide machen im Prinzip das gleiche.


1. In einer dritten Spalte AK die Wahrheitswerte aus AI und AJ mit
ODER verknüpfen und stattdessen diesen Wert zàhlen:

[AK2] = ODER(AI2;AJ2)


2. Die SONST-Zweige beider Formelm in einem ODER zusammenfassen und in
den SONST-Zweig eines neuen WENN schreiben

=WENN(A2=""; "";
ODER(
ODER(UND(MONAT ... )); < kommt aus AI
ODER(DATUM( ... )) < kommt aus AJ
)
)


Peter

Ähnliche fragen