Forums Neueste Beiträge
 
Tags Keywords

Wenn VBA 2.

03/03/2010 - 10:53 von Hora Zender | Report spam
Hallo Peter,

als Antwort kommt Name#

Leider bin ich auch nicht der große VBA Spezi

Danke für die Hilfe

Hora
 

Lesen sie die antworten

#1 Peter Schleif
03/03/2010 - 11:12 | Warnen spam
Hora Zender schrieb am 03.03.2010 10:53 Uhr:

als Antwort kommt Name#



Dann hast Du den Code nicht in ein separates Modul eingefügt, sondern
vermutlich in den Code-Bereich der Tabelle. Zum Einfügen eines separaten
Moduls, wàhle im VBA-Editor den Menüpunkt Einfügen -> Modul. Dort den
neuen Code rein kopieren. Siehe unten.

AFAIK gibt es keine Möglichkeit aus einer Excel-Formel heraus direkt ein
VBA-Makro (Sub) aufzurufen. Es geht nur über den Umweg einer Function.
Ich habe den Code mal etwas abgeàndert, damit Du ihn leichter anpassen
kannst. Die beiden VBA-Funktionen geben jetzt einen leeren String
zurück. Die Zelle mit der WENN-Formel ist also scheinbar leer. In den
Funktionen wird dann jeweils ein Makro aufgerufen, das Du an deine
Bedürfnisse anpassen kannst. Oder Du ànderst gleich den Call-Aufruf.

=WENN(A1=5;VBAWahr();VBAFalsch())

Peter

P.S.: Versuch doch bitte in _einem_ Thread zu bleiben.


Function VBAWahr() As String
Call MeinWahrMakro
End Function

Function VBAFalsch() As String
Call MeinFalschMakro
End Function


Sub MeinWahrMakro()
MsgBox "WAHR"
End Sub

Sub MeinFalschMakro()
MsgBox "FALSCH"
End Sub

Ähnliche fragen