Wenn vorhanden, dann ..

12/11/2013 - 12:06 von Heiko Rompel | Report spam
Moin,

ich möchte unter Excel 2007 folgendes erreichen:

Wenn im Text in der Zelle A1 der Buchstabe "G" enthalten ist, dann
Sollder Inhalt von P1 genommen werden und plus dem Text "G" in die Zelle
T1 geschrieben werden.

Wie muß die Formel aussehen, die ich dafür z.B. in S1 platzieren muss?

Gruß Heiko
 

Lesen sie die antworten

#1 Claus Busch
12/11/2013 - 12:27 | Warnen spam
Hallo Heiko,

Am Tue, 12 Nov 2013 12:06:24 +0100 schrieb Heiko Rompel:

Wenn im Text in der Zelle A1 der Buchstabe "G" enthalten ist, dann
Sollder Inhalt von P1 genommen werden und plus dem Text "G" in die Zelle
T1 geschrieben werden.

Wie muß die Formel aussehen, die ich dafür z.B. in S1 platzieren muss?



du kannst nicht mit einer Formel in S1 einen Wert nach T1 schreiben.
Wenn du diesen Text in T1 haben möchtest, muss die Formel in T1.
Was verstehst du unter " Wenn im Text in der Zelle A1 der Buchstabe "G"
enthalten ist"? Ist das nur ein Zeichen innerhalb eines größeren Textes?
Ist es wichtig, dass es ein großes "G" ist, oder kann es auch ein
kleines g sein?
Soll das "G" direkt an den Text von P1 angehàngt werden oder soll ein
Leerzeichen dazwischen? Was soll sein, wenn G nicht gefunden wird?
=WENN(ISTZAHL(FINDEN("G";A1));P1&" "&"G";"")
Diese Formel sucht nach einem großen "G" und hàngt dieses dann mit einem
Leerzeichen davor an den Text von P1. Wenn nichts gefunden wird, gibt
sie einen Leerstring aus.
Wenn auf Großschreibung nicht geachtet werden soll und auch ein kleines
g erlaubt ist, àndere FINDEN zu SUCHEN


Mit freundlichen Grüßen
Claus
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen