WENN_ZÄHLENWENN

02/03/2009 - 17:47 von Brigitte Cokan | Report spam
Guten Tag zusammen,
mit leuchtet nicht ein, warum Folgendes nicht klappt:
Nur wenn in Spalte A Eintràge vorgenommen wurden (numerische oder Texte)
sollen in Spalte B alle "OK" bzw. "ERROR" gezàhlt werden. Wenn in Spalte B
irgendwo ein "OK" steht, die Nachbarzelle in Spalte A aber leer ist, wird
dieses OK trotzdem gezàhlt. Folgende Formeln funktionieren nicht und zàhlen
eben dieses eine OK immer mit:
{=WENN(ISTLEER($A$2:$A$13);"";WENN($A$2:$A$13>0;ZÄHLENWENN($B$2:$B$13;"OK")))}

=WENN(UND($A$2:$A$13)<=0;"";ZÄHLENWENN($B$2:$B$13;"OK"))

Beide Ergebnisse liefern immer 5, d.h sie zàhlen alle OKŽs unabhàngig von
Bedg. in Spalte A.
Ich danke schon jetzt für Hilfe. Gruß Brigitte
 

Lesen sie die antworten

#1 Dietmar Vollmeier
02/03/2009 - 18:01 | Warnen spam
Servus Brigitte Cokan!

Komisch, Verena Schuster hat genau das gleiche Problem :-/

*Brigitte Cokan* schrieb am 02.03.2009 um 17:47 Uhr...
Nur wenn in Spalte A Eintràge vorgenommen wurden (numerische oder Texte)
sollen in Spalte B alle "OK" bzw. "ERROR" gezàhlt werden. Wenn in Spalte B
irgendwo ein "OK" steht, die Nachbarzelle in Spalte A aber leer ist, wird
dieses OK trotzdem gezàhlt. Folgende Formeln funktionieren nicht und zàhlen
eben dieses eine OK immer mit:
{=WENN(ISTLEER($A$2:$A$13);"";WENN($A$2:$A$13>0;ZÄHLENWENN($B$2:$B$13;"OK")))}

=WENN(UND($A$2:$A$13)<=0;"";ZÄHLENWENN($B$2:$B$13;"OK"))



Versuchs mal mit folgender Formel
=SUMMENPRODUKT(($A$2:$A$13<>"")*($B$2:$B$13="OK"))

HTH
und tschüss | Signaturen sind doof!
Didi |

Ähnliche fragen