Wer hat Lattice-Programmierung mit ispVM und Parallelport-Kabel unter Linux am Laufen?

29/11/2010 - 12:21 von Ansgar Strickerschmidt | Report spam
Hallo NGen,

(ich xposte das mal nach d.c.o.u.l.hardware, weil ich nicht weiss, wo das
besser aufgehoben ist...)

ich habe am Freitag versucht, unter Linux mit dem von Lattice angebotenen
Tool ispVM v17.9 und dem (grauen) original Lattice-Parallelportkabel ein
isPLSI zu programmieren.

Randbedingungen:
- Der Host-Rechner ist ein àlterer Athlon-PC.
- OS ist Ubuntu 10.04.1 LTS.
- Die gesamte Hardware funktioniert mit ispVM 17.x unter Windows korrekt.
- Ich habe mich an die Anweisungen im PDF gehalten, das mit ispVM im Paket
kommt.
Konkret: ich habe den Parallelport auf SPP (testweise auch mal auf ECP
und EPP) gestellt, dafür gesorgt, dass /dev/parport0 die Berechtigungen
666 hat (also world-writeable ist), sichergestellt, dass das Modul
"parport_pc" geladen ist, und die Environmentvariablen korrekt gesetzt.
Ich habe meinen Benutzer außerdem sicherheitshalber auch noch der Gruppe
"lp" hinzugefügt.

Ergebnis: ispVM làsst sich zwar starten und die Oberflàche erscheint, aber
es wird der Lattice-Programmieradapter am Parallelport einfach mal nicht
gefunden. Egal ob von Hand oder per automatischem Scan.

Hat das irgendwer erfolgreich am Laufen? Irgendwelche Tipps, was ich
übersehen haben könnte, oder was ich probieren kann (Tools??), um mehr
über das Nicht-Wollen zu erfahren? Ich gebe zu, ich habe die Systemlogs
noch nicht durchforstet; allerdings erwarte ich mir in diesem Fall an der
Stelle auch keinen großen Erkenntnisgewinn (zu Unrecht??). Einzig "dmesg"
habe ich schon konsultiert, ohne Ergebnis.

Übrigens: habe es auf zwei verschiedenen Systemen mit an sich sehr
àhnlichem Setup ausprobiert. Größter Unterschied: Das eine hat einen SiS-,
das andere einen VIA-Chipsatz, aber beides sind Athlon-Systeme mit Ubuntu
10.04.1 LTS, àhnlicher HD-Aufteilung etc.

leicht ratlos...

Ansgar

*** Musik! ***
 

Lesen sie die antworten

#1 Uwe Bonnes
29/11/2010 - 12:32 | Warnen spam
In de.comp.os.unix.linux.hardware Ansgar Strickerschmidt
wrote:
Hallo NGen,



...

Übrigens: habe es auf zwei verschiedenen Systemen mit an sich sehr
àhnlichem Setup ausprobiert. Größter Unterschied: Das eine hat einen SiS-,
das andere einen VIA-Chipsatz, aber beides sind Athlon-Systeme mit Ubuntu
10.04.1 LTS, àhnlicher HD-Aufteilung etc.



Lasse das Programm mit "strace -f -o <filename> <deine programm> laufen,
und suche nach dem Lauf z.B. mit grep nach dem Teil, wo die parallele
Schnittstelle geoeffnet wird und versuche zu verstehen, warum was nicht
geht.

Tschues
Uwe Bonnes

Institut fuer Kernphysik Schlossgartenstrasse 9 64289 Darmstadt
Tel. 06151 162516 -- Fax. 06151 164321 -

Ähnliche fragen