Werte von Liste in Tabelle übertragen / Suchkriterien in 2 Spalten

21/09/2009 - 20:18 von Joe P | Report spam
Ausgangslage:Tabelle X, 3 Spalten Spalten: A = Lànder, B = Funktionen, C =
Werte. In jedem Land gibts 10-19 Funktionen (uneinheitlich), aber jede max.
einmal. D.h. in Spalte A kann 19 mal dasselbe Land auftreten, für jede
Funktion einmal.
Ziel: ich möchte Tab X in Tabelle Y überführen, wobei pro Land nur noch eine
Zeile gebraucht wird. Die Funktionen werden pro Land auf derselben Zeile
untergebracht.
Beispiel Tabelle X:
Land Fkt Wert
CH 1 b
CH 2 a
CH 3 c
CH .. x
CH 19 b
FR 1 g
FR 2 a
FR 3 d
FR .. x
GB 1 s
GB 3 e
GB 4 s
GB ..
etc.

Zielform:
Land F1 F2 F3 F4 ... F19
CH b a c .. b
FR g a d ..
GB s ? e s
etc.

Ich versuche mit der folgenden Array-Formel, die Werte aus den Spalten von
Tab X in die Zeilen der Tab Y zu übertragen (Formel in jeder Zelle pro
Funktion):
{=IF((X!A2:A99¢)*(X!B2:B99±);X!C2:C99;"?")} oder IF's verschachtelt
{=IF(X!A2:A99¢; IF(X!B2:B99±;X!C2:C70);"?")}
Resultat: es funktioniert nur genau einmal, danach scheint die Formel wie
abzubrechen. Wie bringe ich diese Werte aus der Listen- in einer
Tabellen-Form? Gibt's dazu eine anderer oder bessere Formel (zB LOOKUP mit
Bedingungen in 2 Spalten). Tabelle X kann bis zu 855 Zeilen haben (45 Lànder
x 19 Funktionen) haben und sollen tàglich in eine One-Pager-Report übertragen
werden. Hilfe!!!
(und sorry für die lange Beschreibung)
 

Lesen sie die antworten

#1 Thomas Ramel
21/09/2009 - 20:52 | Warnen spam
Grüezi Joe

Joe P schrieb am 21.09.2009

Ziel: ich möchte Tab X in Tabelle Y überführen, wobei pro Land nur noch eine
Zeile gebraucht wird. Die Funktionen werden pro Land auf derselben Zeile
untergebracht.
Beispiel Tabelle X:
Land Fkt Wert
CH 1 b
CH 2 a
CH 3 c
CH .. x
CH 19 b
FR 1 g
FR 2 a
FR 3 d
FR .. x
GB 1 s
GB 3 e
GB 4 s
GB ..
etc.



Füge hier in Spalte D eine Hilfsspalte namens 'Index' ein die folgende
Formel enthàlt:

¢&B2

(Voraussetzung ist, dass die Daten in A1 beginnen)

Zielform:
Land F1 F2 F3 F4 ... F19
CH b a c .. b
FR g a d ..
GB s ? e s
etc.



Auch hier sollten Lànder und Funktionen in der ersten Zeile/Spalte stehen,
dann kannst Du in B2 die folgende Formel verwenden und nach unten/rechts
kopieren:

xl2007:
=WENNFEHLER(INDEX(X!$C:$C;VERGLEICH(Y!$A2&B$1;X!$D:$D;0);1);"")

xl2003 und früher:
=WENN(ZÄHLENWENN(X!$D:$D;Y!$A2&B$1)=0;"";INDEX(X!$C:$C;VERGLEICH(Y!$A2&B$1;X!$D:$D;0);1))



Mit freundlichen Grüssen
Thomas Ramel

- MVP für Microsoft-Excel -
[Vista Ultimate SP-1 / xl2007 SP-1]

Ähnliche fragen