Wie finde ich mein Toleranzen?

27/11/2007 - 20:32 von Ralf Lehmeier | Report spam
Hallo!
Ich möchte eine Tabelle anlegen aus der ich Toleranzen entnehmen kann.
Das Problem ist das ich keine Möglichkeit finde in dieser Tabelle zu
suchen. Mit Sverweis komme ich leider nicht weiter da im Grenzbereich
immer der kleinere Wert übernommen wird. So z.B. sieht sie aus:

Nennmaß ninimal maximal
0 - 3 mm 0 +0,006 mm
3 - 6 mm 0 +0,008 mm
6 - 10 mm 0 +0,009 mm
10 - 18 mm 0 +0,011 mm

Das Problem liegt daran das Sverweis immer den ersten Wert nimmt den er
findet oder eben den nàchstkleineren Wert. Mit dem nàchstkeineren ist es
nicht schlimm - das passt ja aber wenn ich

Der Nachteil bei den Toleranzen ist nàmlich das z.B der Wert 6 mm gleich
2 mal auftaucht. bei 3- 6 und bei 6 - 10. Im ersten Fall gelten die 6mm
bis einschließlich 6,0. Im 2.Fall ist alles >6 -10,0 mm gemeint. hier
weiß ich aber nicht wie eine solche Abfrage aussehen könnte.

dies ist ein Versuch gewesen das Problem zu umgehen
6 0,0000 0,0080 0,0040
6 0,0000 0,0080 0,0040
10 0,0000 0,0090 0,0045
10 0,0000 0,0110 0,0055
18 0,0000 0,0110 0,0055
18 0,0000 0,0130 0,0065

Eine solche Variante mit Sverweis hat mir leider auch nicht weitergeholfen.

Besser wàre es wo ich die ersten 2 Spalten auswerten kann und dann die
3,4 oder 5 spalte ausgegeben bekomme.

Wenn jemand eine Lösung hat wàre ich Dankbar für die Hilfe.
Ich verwende Openoffice 2.3

MfG R.Lehmeier
 

Lesen sie die antworten

#1 Siegfried Höfner
27/11/2007 - 22:22 | Warnen spam
"Ralf Lehmeier" schrieb:
Hallo!
Ich möchte eine Tabelle anlegen aus der ich Toleranzen entnehmen kann.
Das Problem ist das ich keine Möglichkeit finde in dieser Tabelle zu
suchen. Mit Sverweis komme ich leider nicht weiter da im Grenzbereich
immer der kleinere Wert übernommen wird. So z.B. sieht sie aus:

Nennmaß ninimal maximal
0 - 3 mm 0 +0,006 mm
3 - 6 mm 0 +0,008 mm
6 - 10 mm 0 +0,009 mm
10 - 18 mm 0 +0,011 mm




[...]

Hallo Ralf,
wenn ich dein Problem richtig verstanden habe, dann geht so etwas am besten
mit Matrixformeln, mit SVERWEIS eher nur mit vielen Hilfsoperationen/Spalten.

Beispiel: Die Werte stehen in A3 bis D6 ; A8 dient als Eingabe für den Suchwert.
C8 enthàlt Matrixformel für "min" und D8 für "max".

in C8 : =SUMME( ((A3:A6)<$A$8)*((B3:B6)>=$A$8)*(C3:C6))
in D8 : =SUMME( ((A3:A6)<$A$8)*((B3:B6)>=$A$8)*(D3:D6))
beides als Matrixformel eingeben ( beenden mit CTRL/SHiFT/Enter), dabei werden
die geschweiften Klammern gesetzt.

A B C D
1 von bis min max
2
3 0 3 0 0,006
4 3 6 0 0,008
5 6 10 0 0,009
6 10 18 0 0,011
7
8 4 0 0,008

Gruß Siegfried

Ähnliche fragen