Wie Troubles mit Roaming profiles eingrenzen?

03/01/2008 - 14:01 von Peter Mairhofer | Report spam
Hi,

Ich habe wieder grobe Probleme mit meinen "Roaming profiles". Es kommt hin
und wieder einfach vor dass das Profil zwar ohne Fehlermeldung laedt,
jedoch Windows trotzdem die Defaulteinstellungen laedt.
Manchmal gibt es ein "Misch-Masch". Die Dateien vom Profil werden
uebernommen (Eigene Dateien, Desktop), die Registry jedoch nicht (Thema,
Layout des
Startmenues, ...).
Das schlimme dran: Nach dem Abmelden ist das "echte" Profil auf dem Server
futsch und durch das "neue" Defaultprofil ersetzt.

Mich wuerde nun interessieren WANN genau diese Effekte auftreten und wie
ich schrittweise die Fehler eingrenzen kann.

Ich habe bereits eines gemerkt: Der Fehler tritt z.B. auf, wenn sich die
SID des Benutzers geàndert hat. Im konkreten Fall kann das aber nicht sein,
denn die SIDs in der Registry passen, die ntuser.dat laesst sich ohne
Probleme oeffnen und es besteht kompletter Zugriff auf das Profil am
Server.

Gibt es so eine Art Checkliste was ich alles untersuchen koennte?

Bereits untersucht habe ich:
- Ich kann alles lesen und schreiben auf \\Server\\profiles\\username
- Ich kann die ntuser.dat zum Lesen und Schreiben oeffnen
- Die SID des Benutzers passt
- Wenn ich die ntuser.dat in der Registry oeffne und die Berechtigungen
checke hat der Benutzer ebenso Lese-/Schreibrechte.

Leider verschweigt hier Windows komplett was es macht was das Handling mit
Profilen ungemein schwierig macht :-(

LG,
Peter

PS: Die Profile sind auf einem Samba PDC. Das soll und darf aber in meinem
Fall keinen Umstand darstellen da Samba keine Fehler meldet und alle
Dateien geladen werden, incl. der ntuser.dat. Ich moechte verstehen, wie
Windows mit den Profilen umgeht.
 

Lesen sie die antworten

#1 Thorsten Kampe
03/01/2008 - 14:09 | Warnen spam
* Peter Mairhofer (Thu, 03 Jan 2008 05:01:51 -0800)
Ich habe wieder grobe Probleme mit meinen "Roaming profiles". Es
kommt hin und wieder einfach vor dass das Profil zwar ohne
Fehlermeldung laedt, jedoch Windows trotzdem die
Defaulteinstellungen laedt.
Mich wuerde nun interessieren WANN genau diese Effekte auftreten und wie
ich schrittweise die Fehler eingrenzen kann.



Debugprotokollierung für die Benutzerumgebung:
http://support.microsoft.com/?id"1833

Ich habe bereits eines gemerkt: Der Fehler tritt z.B. auf, wenn sich
die SID des Benutzers geàndert hat.



Die SID eines Benutzers /kann/ sich nicht àndern.

T.

Ähnliche fragen