Wieder einmal Stundenberechnung

08/10/2007 - 10:17 von Wolfgang Schirmer | Report spam
Hallo zusammen,

mir fehlt mal wieder eine kleine Ergànzung einer Funktionalitàt und bin
sicher man kann mir hier wie schon so oft helfen. Also, folgendes ist
gegeben.

A1 bis AE1 = Datumsangabe 01. bis 31. Oktober
A2 bis AE2 = Eintragungen für Schicht und diverse (F; S; N; UR; KR
selbsterklàrend ;-)
In AF2 berechne ich die Anzahl der Arbeitstage incl. KR (krank) oder UR
(Urlaub) mit =ANZAHL2(A2:AE2) was auch so funktioniert wie es soll.
In AG2 will ich die Gesamtstunden berechnen, wobei folgende
Stundenzahlen vorgegeben sind:

F = 7,25
S und N = 7,5
UR und KR = 7,6

Solange F; S und N auf einen Wochentag fàllt ist es auch kein Problem,
denn dann sieht meine Formel folgendermassen aus:

=(ZÄHLENWENN(A2:AE2;"F")*7,25)+(ZÄHLENWENN(A2:AE2;"S")*7,5)+(ZÄHLENWENN
(A2:AE2;"N")*7,5)+(ZÄHLENWENN(A2:AE2;"UR")*7,6)+(ZÄHLENWENN(A2:AE2;"KR"
)*7,6)

Jetzt kommt mein Problem, denn wenn F auf einen Samstag, Sonntag oder
Feiertag fàllt (z.B. M2 oder N2) dann sind es auch 7,5 und wenn S oder
N auf solche Tage fallen, dann sind es 7,75.

Puhhh, ich hoffe ich habe es richtig erklàrt. Komme hier nicht so
richtig weiter wie ich diese Bedingungen reinbringen. Es soll aber in
der Formel erscheinen und nicht über ein Makro gelöst werden. Hat da
jemand eine Idee für mich?

Danke schon mal

mfG Wolle S.
 

Lesen sie die antworten

#1 Alexander Wolff
08/10/2007 - 10:56 | Warnen spam
Füge vor Zeile 1 eine ein, also:

Zeile 1: Wochenend- oder Feiertag
2: Datümer
3: erste Schichtzeile

Tabelle2!$A$1:$A$15: Feiertage eintragen (evtl. kürzen oder verlàngern!)

A1: =--ODER((REST(A2;7)<2);ISTZAHL(VERGLEICH(A2;Tabelle2!$A$1:$A$15;)))
bis AE1 kopieren

AG3:
=SUMMENPRODUKT((A3:AE3={"F";"S";"N";"UR";"KR"})*({7,25;7,5;7,5;7,6;7,6}
+($A$1:$AE$1=1)*{0,25;0,25;0,25;0;0}))

Du kannst natürlich auch statt auf {"F";"S";"N";"UR";"KR"} auf
Tabelle2!$B$1:$B$5 zugreifen, wo Du diese Werte eintràgst, entspr. auch
{7,25;...} und {0,25;...}. Ist besser und kürzer.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen