Wieder Sortierung

09/09/2009 - 06:52 von Jan-Thomas Kühnert | Report spam
Hallo,

ich habe ein àhnliches Problem. Meine zu ordnenden Werte sind wie unten
dargestellt aufgebaut. Dies ist schon die Ordnung, welche die
Pivottabelle hergibt. Ziel ist jedoch die natürliche Ordnung der Zahlen
_ohne_ Berücksichtigung des "W" aber _mit_ Unterscheidung über "A" und "B".

Das manuelle Verlàngern der Stellenanzahl auf W00X bzw. W0XX ist für
1400 Werte untauglich.

=WENN(LÄNGE(A2)<=2;VERKETTEN("W00"&RECHTS(A2;1))) hilft nur für die
einstelligen Werte.

Kann mir geholfen werden?

Vielen Dank,
Jan-Thomas

W1
W10
W101B
W102
W102B
W111A
W111B
W112A
W112B
W113A
W113B
W114A
W114B
W115A
W115B
W116A
W116B
W117A
W117B
W118A
W118B
W119A
W119B
W11B
W12
W120A
W120B
W121A
W121B
W122A
W122B
W123
W13
W14
W15
W17
W18
W19
W2
W20
W21
W22
W23
W24
W25
W26
W27
W28
W29
W3
W30
W31
W32
W33
W34
W35
W35B
W36
W37
W38
W39
W4
W41A
W42B
W44A
W44B
W45A
W45B
W46A
W46B
W47A
W48A
W48B
W49A
W5
W50B
W53B
W54A
W57A
W57B
W59B
W6
W60B
W61A
W61B
W62A
W62B
W63A
W63B
W64A
W65A
W65B
W66A
W66B
W67A
W67B
W68A
W69B
W7
W70B
W73A
W73B
W74A
W74B
W75B
W76A
W76B
W77A
W78A
W78B
W79A
W8
W81A
W81B
W82B
W85B
W9
W97A
W97B
W98B
W99B
 

Lesen sie die antworten

#1 Alexander Wolff
09/09/2009 - 09:19 | Warnen spam
Die Tastatur von Jan-Thomas Kühnert wurde wie folgt gedrückt:
ich habe ein àhnliches Problem.



Wie wer?

Meine zu ordnenden Werte sind wie
unten dargestellt aufgebaut. Dies ist schon die Ordnung, welche die
Pivottabelle hergibt. Ziel ist jedoch die natürliche Ordnung der
Zahlen _ohne_ Berücksichtigung des "W" aber _mit_ Unterscheidung über
"A" und "B".



Dein Beispiel ist gut sortiert. Was soll genau anders sein?

Das manuelle Verlàngern der Stellenanzahl auf W00X bzw. W0XX ist für
1400 Werte untauglich.

=WENN(LÄNGE(A2)<=2;VERKETTEN("W00"&RECHTS(A2;1))) hilft nur für die
einstelligen Werte.



Du hast im Beispiel schon 3stellige Zahlen. Willst Du den Zahlenraum von 2
auf 3 Zahlenstellen bringen oder von 3 auf 4?

="W0"&TEIL(A2;2;4)

müßte reichen, da

- alles mit W beginnt und weiter beginnen soll
- nur eine Stelle eingefügt werden soll

Du zeigst ja keine Ursprungsdaten, sondern nur eine gewünschte Sortierung.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen