Wiedergabe von DVDs im Media Center die auf Platte gespeichert sin

27/08/2007 - 13:16 von Volker Busch | Report spam
Hallo Newsgroup,
habe nachdem mir selbstgebrannte DVDs sehr oft kaput gegangen sind, die DVDs
auf ner externen USB Festplatte abgelegt.
Hatte das Media Center schon auf XP Basis, da klappte alles einwandfrei. Ich
ging auf Videos, mir wurden die Ordner in denen ich die DVD Filme abgelegt
hatte angezeigt.
Klickte ich auf den Ordner, dann ging sofort der DVD-Film an. (Ohne
Unterordner und dateien anzuzeigen)

Jetzt mit Vista werden mir auch die Ordner angezeigt, klicke ich allerdings
auf einen Ordner wird mir der Unterordner <VIDEO_TS> angeigt, klicke ich da
nochmals drauf sehe ich nur die einzelnen <VTS_xx_x> Dateien (Nicht aber eine
Startdatei des Videos), klicke ich auf eine der angezeigten *.VOB Dateien,
dann wird der Bildschirm schwarz, ich höre Ton, das ist aber auch alles.

Habe mir extra Power DVD Besorgt, das spielt die DVDs auf dem PC korrekt ab.
(Auch Nero7 ist auf dem PC und spielt die Videos.

FRAGE
1) wie funktioniert denn die DVD ausgabe auf dem media Center?
Brauche ich da zusàtzlich Codecs (hab schon ein Packet installiert) oder ein
Plug In?

Hmm auf XP wars so schön...


LG Volker
 

Lesen sie die antworten

#1 G.Born
27/08/2007 - 16:14 | Warnen spam
Hallo Volker

habe nachdem mir selbstgebrannte DVDs sehr oft kaput gegangen sind, die
DVDs
auf ner externen USB Festplatte abgelegt.
Hatte das Media Center schon auf XP Basis, da klappte alles einwandfrei.
Ich
ging auf Videos, mir wurden die Ordner in denen ich die DVD Filme abgelegt
hatte angezeigt.
Klickte ich auf den Ordner, dann ging sofort der DVD-Film an. (Ohne
Unterordner und dateien anzuzeigen)

Jetzt mit Vista werden mir auch die Ordner angezeigt, klicke ich
allerdings
auf einen Ordner wird mir der Unterordner <VIDEO_TS> angeigt, klicke ich
da
nochmals drauf sehe ich nur die einzelnen <VTS_xx_x> Dateien (Nicht aber
eine
Startdatei des Videos), klicke ich auf eine der angezeigten *.VOB Dateien,
dann wird der Bildschirm schwarz, ich höre Ton, das ist aber auch alles.

Habe mir extra Power DVD Besorgt, das spielt die DVDs auf dem PC korrekt
ab.
(Auch Nero7 ist auf dem PC und spielt die Videos.

FRAGE
1) wie funktioniert denn die DVD ausgabe auf dem media Center?
Brauche ich da zusàtzlich Codecs (hab schon ein Packet installiert) oder
ein
Plug In?

Hmm auf XP wars so schön...




Eine Antwort oder Lösung kann ich Dir momentan nicht bieten - hab mir das
aber auch noch nicht genauer angesehen. Ich erinnere mich aber (könnte hier
in der Gruppe gewesen sein) an eine Diskussion vor ca. 2. Monaten, wo genau
so was mal mit einem anderen Poster in Bezug auf den WMP diskutiert wurde.
Von DVD auf eine externe Festplatte geripptes MPEG-2-Material ließ sich im
WMP nicht mehr abspielen. Lag es auf der lokalen Festplatte, lief es. Da WMP
und VMC die gleichen DirectShow-Filter bzw. MF-Bibliotheken verwenden,
dürfte das Verhalten auch àhnlich sein.

Allein, ich kenne die "Vorgeschichte" Deines Systems nicht - muss also mal
wieder etwas spekulieren:

Ein mögliches Szenario: Es wird im Media Foundation Framework erkannt, dass
die Datenströme von einem externen Laufwerk kommen, welches aber kein
DVD-Drive darstellt (es fehlt der Regioncode). Könnte sein, dass dann der
"Media Protection Paths" zuschlàgt und die Inhalte nicht wiedergegeben
werden. Ist aber - fairerweise muss ich das dazu sagen - momentan noch etwas
spekulativ (und würde dem widersprechen, was ich da bisher über das
Downscaling gelesen habe.

Dass PowerDVD und Nero 7 ShowTime die MPEG-2-Dateien in den VOBs
wiedergeben, wàre erklàrbar. Beide Programme verwenden meines Wissens keine
Funktionen des Media Foundation-Framework und können wohl angeben, welche
DirectShow-Filter bzw. MPEG-2-Decoder verwendet werden sollen.

Zweites Szenario: Du hast Dir ggf. durch die Installation der diversen
Pakete das Vista DirectShow-System etwas ruiniert. Vor allem die Aussage
"Brauche ich da zusàtzlich Codecs (hab schon ein Packet installiert) oder
ein Plug In?" làsst mich böses befürchten. Daher möchte ich einige Fragen
stellen, um vielleicht eine Antwort zu finden.

- Wann hast Du das Problem festgestellt? Bevor oder nachdem Du Nero
installiert hast?
- Falls das Problem nach der Nero-Installation auftrat, würde mich die
Version des Nero-Pakets interessieren.

Das zweite, was mich brennend interessiert: Hast Du mal Nero und PowerDVD
versuchsweise deinstalliert und NeroClean (http://www.silent-dreams.de/)
anschließend drüber laufen lassen? Làuft es dann? Dann wàre die Erklàrung,
dass eines dieser Pakete Filter im DS installiert, die einfach nicht in der
Lage sind, die VOBs von USB-Medien zu lesen.

Falls mir da noch was unter die Augen oder eine Idee kommt, melde ich mich
wieder. Du kannst ja ggf. auch eine Rückmeldung geben, wenn Du noch was
rausfindest. Kann es hier mangels externer Festplatte nicht testen (Umbau
eines USB-Gehàuses für einen DVD-Brenner auf eine ATA-Festplatte ist mir
momentan zu 'Zeit'-aufwàndig).

Vielleicht kannst Du ja eine Rückmeldung geben - ich habe mir den Thread mal
im Reader markiert, um die Diskussion zu verfolgen.

Gruß

G. Born

Ähnliche fragen