Win7 - Domänenbeitritt klappt nicht - Experiment 2

12/02/2011 - 08:13 von Knut Singer | Report spam
Hi,

heute habe ich ein ganz frisch aufgesetztes Windows 7, völlig
jungfràulich, nur mit den 2 entsprechenden Keys für die
Domànenkompatibilitàt und dem Verzicht auf den DNS versehen, versucht in
meine Samba Domàne zu bringen - wieder ohne Erfolg.
Und wieder ohne eine einzige Zeile im Logfile von Samba von diesem
Versuch zu sehen.

Allerdings habe ich nun etwas systematischer geforscht und vermutlich
das Problem gefunden:
Der Samba-Server meldet sich per Netbios nicht als <0x1C> im Netz, also
nicht als Domànencontroller.

Bevor ich nun die ganzen Tests aufrolle: Vielleicht weiß schon hier
jemand, was hier faul sein könnte?
Was muss Samba-Server Einstellungen àndern, damit er sich auch als
<0x1C> für die Domàne/Arbeitsgruppe im Netz meldet?

Nun ausführlich:

Testumgebung:
a) Sernet Samba 3.5.6 auf CentOS 5.5
b) Win7 ganz frisch, mit den erforderlichen Registry-Keys und natürlich
neu gestartet.

Die beiden hàngen gemeinsam ohne irgendwelche Kontakte zu anderen
Rechnern oder Routern an einem Switch, sodass Fremdeinflüsse
ausgeschlossen sind.

Der Zugriff von Win7 auf den Samba-Server ohne Beitritt in die Domàne
auf eine Test-Freigabe funktioniert tadellos.

Beim Versuch, der Domàne beizutreten, erscheint (stark gekürzt) folgende
Fehlermeldung:

"Keine Verbindung mit Active Directory Domànencontroller für Domàne
"KANZLEI". <- Domànen bzw. Workgroup Name in Netbios

KANZLEI ist evtl. ein Netbiosname... stellen Sie sicher, dass bei Wins
registriert.

Wenn kein Netbiosname, dann konnte SRV-Eintrag in DNS-Server nicht
gefunden werden: __ldap._tcp.dc._msdcs.kanzlei

"

OK, den Fehler mit dem nicht vorhanden SRV-fàhigen DNS-Server gibt es
natürlich, aber was ist blos mit dem Netbios Namen KANZLEI los?


Also habe ich mal mit einem Paketsniffer geschaut, was der WIN7-Rechner
da so an Anfrage abschickt..
Und siehe da, es war 3 mal hintereinander ein Broadcast namens "NbtNs:
QueryRequest for KANZLEI <0x1C>, der unbeantwortet bleibt.

Nun noch einmal eine Kontrolle mit nbtstat -a server4 (so heißt der
Problem-Samba-Server) ergibt:

eine wunderbare Liste, nur <0x1C> fehlt!:

SERVER4 <00> Eindeutig Registriert
SERVER4 <03> Eindeutig Registriert
SERVER4 <20> Eindeutig Registriert
..__MSBROWSE__. <01> Gruppe Registriert
KANZLEI <10> Eindeutig Registriert
KANZLEI <1B> Eindeutig Registriert
KANZLEI <1E> Gruppe Registriert
KANZLEI <00> Gruppe Registriert


Ich denke nun, dass mein einziges Problem ist, dass sich der
Samba-Server nicht als Domànencontroller mit 1C melden mag.

Wahrscheinlich ist das ganz simpel zu lösen?

Übrigens: Ein nbtstat mit dem alten Samba 2.0.23 im momentan genutzten
Netz ergab dort ein 1C... wie zu erwarten.

WINS habe ich mehrfach in Samba ein- und ausgeschaltet, nmbd làuft
natürlich auch... ich bin ratlos...

.. und dankbar für jede Hilfe..

Danke,
Knut

Nachtrag: Die Samba-Config ist ganz winzig, nur eine Testfreigabe, die
ich hier mal weglasse, das sie ja per Share funktioniert und folgende
Grundeinstellungen, die Testparm liefert:

Workgroup = KANZLEI
Realm = server4.meinedomain.de
Interfaces= 127.0.0.1, Eth0
Bind Interfaces only = Yes
Domain Master = Yes

Was Testparm nicht anzeigt:
Rechtemodus habe ich natürlich auf USER gesetzt, WINS mal ein und mal
aus, und Winbind die ganze Zeit aus, da ja kein anderer DC im Spiel ist...
 

Lesen sie die antworten

#1 Stefan Dreyer
12/02/2011 - 11:52 | Warnen spam
On 02/12/11 08:13, Knut Singer wrote:
[...]
Nachtrag: Die Samba-Config ist ganz winzig, nur eine Testfreigabe, die
ich hier mal weglasse, das sie ja per Share funktioniert und folgende
Grundeinstellungen, die Testparm liefert:

Workgroup = KANZLEI
Realm = server4.meinedomain.de
Interfaces= 127.0.0.1, Eth0
Bind Interfaces only = Yes
Domain Master = Yes



Fehlt da nicht noch ein
domain logons = Yes?

Was Testparm nicht anzeigt:
Rechtemodus habe ich natürlich auf USER gesetzt, WINS mal ein und mal
aus, und Winbind die ganze Zeit aus, da ja kein anderer DC im Spiel ist...

Ähnliche fragen