Win7 und Aero - Bugs in der GUI?

14/06/2011 - 14:09 von Arno Welzel | Report spam
Folgender Bug kann in Windows 7 mit Aero (auch Aero Basic) beobachtet
werden, auch in SP1, was ich ziemlich schade finde:

Man àndere die Farben für "markierte Elemente", z.B. auf schwarzer
Hintergrund und weißer Text, weil einem die blaue Hintergrundfarbe für
markierte Elemente nicht zusagt:

<http://arnowelzel.de/samples/win7-c...gs.png>

Dann öffne man das Menü des Explorers, indem man die Alt-Taste drückt.

Ergebnis: Der selektierte Menütitel erscheint als schwarzer Kasten, da
die Texte von Menütiteln im Explorer sich offenbar nicht an die Vorgabe
für die Einstellung halten, sondern nur der Hintergrund:

<http://arnowelzel.de/samples/win7-e...nu.png>

Man sieht auch, wàhrend das Menü geöffnet wird, dass der Menütitel ganz
kurz so erscheint, wie es vom Theme offenbar gedacht ist, dann aber eben
als einfacher Text mit farbigem (bzw. hier eben schwarzem) Hintergrund
dargestellt wird.

Interessanterweise ist die Behauptung, die Farbeinstellungen würden für
Aero nicht gelten, auch schlicht falsch - in der Adressleiste des
Explorers wird die ausgewàhlte Farbeinstellung sehr wohl beachtet:

<http://arnowelzel.de/samples/win7-e...ss.png>

Ich habe das allen beugtachteten Installation so reproduzieren können -
offenbar ist das ein "Feature" :-/

Gibt es alternative Aero-Themes, die diesen Bug nicht haben?


http://arnowelzel.de
http://de-rec-fahrrad.de
 

Lesen sie die antworten

#1 Hans-Peter Matthess
14/06/2011 - 14:18 | Warnen spam
Arno Welzel:

Gibt es alternative Aero-Themes, die diesen Bug nicht haben?



Keine Ahnung, ich hab allerdings die Erfahrung gemacht, dass gewisse
Einstellungen auf dieser Karte nur dann wirksam sind, wenn man nicht
Aero verwendet.

hpm

Ähnliche fragen