Windows 7 und alternative Bootloader / bleibt beim Laden von CLASSPNP.SYS haengen.

26/08/2009 - 18:22 von Heiko Pliefke | Report spam
Hallo Leute!

es gibt wohl noch keine Win7-NG, daher stell ichs mal bei bei Vista ;)

Ich moechte gern auf einem Notebook ein XP ein Win7 und - wenn moeglich
- ein Ubuntu parallel betreiben.
Die Windows-System wuerde ich gern auf primaeren Partitionen
installieren und sie gegenseitig verstecken. Dem Linux ist das ja wurscht.

Dieses Szenario hatte bis zuletzt (2 XPs und 1 Ubuntu) auch hervorragend
geklappt. GRUB hat jeweils die XP-Partition aktiviert und gebootet,
sowie das Ubuntu.

Mit Windows7 bekomme ich das nicht hin - aber der Reihe nach:

Vorbedindung: WinXP auf erster Primaerer Partition / zweite primaere
leer. Ubuntu auf Extended (logical)...

1.) Windows 7 installiert:
Die Installation ueberschreibt (erwartungsgemaess) den MBR mit dem
eigenen Bootloader und schreibt dann den Bootmanager entweder in die
erste Partition (*A*) (wo XP liegt) oder in die zweite (*B*) (wo Seven
liegt) - habe beide Moeglichkeiten ausprobiert.
WinXP laden.

2.) GRUB repariert:
Wenn ich dann GRUB wieder repariere, kann ich weiterhin hervorragend
Ubuntu oder WinXP auf der ersten Partition starten.
Im Fall *A* startet dann WinXP direkt mit eigenem NTLDR.
Im Fall *B* startet der Win7-BootMgr und bringt mir noch die Auswahl von
XP und Seven.
Wie gesagt - in beiden Faellen funktioniert XP - aber Windows7 haengt
sich beim Booten auf. Noch nicht mal der abgesicherte Modus geht und
auch "startup repair" etc. funktioniert nicht.
Die letzte Datei, die beim Booten geladen wird ist "CLASSPNP.SYS".


Kann mir jemand erklaeren, warum das da haengt und nicht funktioniert?
Und was es mit der ominoesen CLASSPNP.SYS auf sich hat?

Woran stoert sich Win7? Der Bootloader/Bootmgr scheint ja zu
funktioniert, Win7 faehrt ja hoch... nur leider nicht bis zum Ende.

Wie gesagt - mit XP und damals(TM) mit Win2K hat das Szenario noch
funktioniert.

Das Problem haengt aber eindeutig mit dem MBR zusammen - ich hab Seven
jetzt 3mal neuinstalliert und jedesmal nach dem Repair von GRUB haengt
es an der gleichen Stelle.

Verschiedene GRUB-Configs habe ich schon probiert (chainloaeder+4 und
solche Scherze) oder Repair von Seven (startup repair oder von Inst.DVD).

Hat hier jemand eine Idee?

Vielen Dank schonmal fuers Lesen - ist etwas laenger geworden :-/
Schoene Gruesse
Heiko Pliefke
 

Lesen sie die antworten

#1 Matthias Berke
27/08/2009 - 21:40 | Warnen spam
Heiko Pliefke wrote:

Ich moechte gern auf einem Notebook ein XP ein Win7 und - wenn
moeglich - ein Ubuntu parallel betreiben.
Die Windows-System wuerde ich gern auf primaeren Partitionen
installieren und sie gegenseitig verstecken. Dem Linux ist das ja
wurscht.

Dieses Szenario hatte bis zuletzt (2 XPs und 1 Ubuntu) auch
hervorragend geklappt. GRUB hat jeweils die XP-Partition aktiviert
und gebootet,
sowie das Ubuntu.

Mit Windows7 bekomme ich das nicht hin - aber der Reihe nach:



http://www.pc-experience.de/wbb2/th...p?threadid(999

Matthias

Ähnliche fragen