Windows-8 - Problem mit MSCOMCTL.OCX

31/05/2013 - 19:15 von Dieter Strassner | Report spam
Hallo NG'ler,

möchte meine (virtuelle) Entwickler-Maschine von XP auf W8 umziehen.

Die W8 (64) làuft nun (auch die VB6-IDE), jedoch mach das MSCOMCTL.OCX
Probleme.
Es ist nicht benutzbar. beim zuordnen als Komponente zu einem VB-projekt
kommt nur die lapidare Meldung, das ein Fehler gibt.
Beim öffnen eines Projektes, das die Komponente benutzt, heipßt es dann im
Log z.B.:

Zeile 17: Klasse MSComctlLib.ImageList des Steuerelements ImgList war keine
geladene Steuerelementklasse.

Die neue Maschine hat ebenfalls VB6-SP6 (da steckt das mscomctl ja drin).

Das merkwürdige für mich:
auf der alten XP-Maschine habe den Eintrag:
MSCOMCTL.OCX Version 6.01.9834 vom 6.6.2012

auf Windows-8:
MSCOMCTL.OCX Version 6.01.9816 vom 24.3.2009

Dachte mir bisher. ich akkurat bei Update meiner Entwicklermaschine alle
Updates/SPs gespeichert und notiert. Aber irgendwas muß ich vergessen haben.

Kann mir da jemand weiterhelfen? Danke!

Viele Grüße - Dieter

EDV-Kommunikation Strassner e.K.
68623 Lampertheim
Internet: www.strassner.biz
 

Lesen sie die antworten

#1 Dieter Strassner
01/06/2013 - 16:29 | Warnen spam
Hallo,

als "Workaround" habe ich die mscomctl.ocx aus dem alten XP-System in das
W8-SysWOW64-Verzeichnis kopiert und registiert. Es sieht so aus, als würde
nun alles funktionieren (...mal vorsichtig gesprochen). Falls jemand
Bedenken zur Vorgehnsweise hat oder eine bessere Idee, gerne her damit :-)

Viele Grüße - Dieter

EDV-Kommunikation Strassner e.K.
68623 Lampertheim
Internet: www.strassner.biz

Ähnliche fragen