Windows XP Bootloader/ Multiboot mit mehreren Festplatten

15/10/2010 - 11:49 von Daniel Meszaros | Report spam
Hi,

ich habe mir auf einer zweiten Festplatte ein Linux-System installiert,
das ich nun über das WindowsXP-Bootmenü starten will.

Ich habe mittels BootPart (http://www.winimage.com/bootpart.htm) den
Bootsektor extrahiert und in die BOOT.INI integriert:

[boot loader]
timeout0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /noexecute=optin /fastdetect
C:\CitXenSrv.MBR="Citrix XenServer Free"

Leider bekomme ich das System nicht gestartet. Nun tippte ich drauf,
dass die zweite Festplatte das Problem sein wird und probierte es ohne
extrahierten Bootsektor:

[boot loader]
timeout0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /noexecute=optin /fastdetect
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Citrix XenServer Free"

Ebenfalls erfolglos.

Ich habe das Problem in einem anderen Fall mal mit der Einbindung von
GRUB4DOS gelöst, würde es aber gern direkt mit den Windows-Mitteln
umsetzen. Kennt jemand einen praktikablen Lösungsansatz?

CU,
Mészi.
 

Lesen sie die antworten

#1 Martin Freitag
15/10/2010 - 12:38 | Warnen spam
Daniel Meszaros schrieb:
ich habe mir auf einer zweiten Festplatte ein Linux-System installiert,
das ich nun über das WindowsXP-Bootmenü starten will.

Ich habe mittels BootPart (http://www.winimage.com/bootpart.htm) den
Bootsektor extrahiert und in die BOOT.INI integriert:

[boot loader]
timeout0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /noexecute=optin /fastdetect
C:\CitXenSrv.MBR="Citrix XenServer Free"

Leider bekomme ich das System nicht gestartet. Nun tippte ich drauf,
dass die zweite Festplatte das Problem sein wird



Möglicherweise, bisher habe ich extrahierte Bootsektoren auch nur auf
einer Festplatte benutzt, da funktionierte sowas. Hoffentlich kann
diesbezüglich noch jemand Licht ins Dunkel bringen, ansonsten wirds wohl
auf einen anderen Bootmanager hinauslaufen.


und probierte es ohne extrahierten Bootsektor:

[boot loader]
timeout0
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
Professional" /noexecute=optin /fastdetect
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Citrix XenServer Free"

Ebenfalls erfolglos.




Also das _kann nicht_ gehen, solange im angegeben Pfad kein Windows
"wartet". ;-)
Gruß

Martin
() ascii ribbon campaign - against html e-mail
/\ www.asciiribbon.org - http://www.asciiribbon.org/index-de.html

Ähnliche fragen