Windowsmail, unterstützt das Mailto Protokoll nicht mehr

07/10/2007 - 09:08 von Helmut Hiller | Report spam
Hallo,

ich hatte mit verschiedenen Mailclients experimentiert, auch wieder
deinstalliert. Seitdem kann ich eigentlich nur noch Thunderbird richtig
verwenden. Windowsmail z.B. kann ich zwar als Standard setzen, jedoch
funktioniert Mailto:... nicht mehr.

Folgenden Tipp dazu habe ich erhalten:



Öffne in der Systemsteuerung "Standardprogramme" und darin
auf "Standardprogramme festlegen". Klicke links unter
"Programme" auf "Windows Mail" und dann rechts auf
"Dieses Programm als Standard festlegen".
Klicke danach auf "Standards für dieses Programm auswàhlen"
und im sich daraufhin öffnenden Fenster setze ein Hàkchen
vor "Alle auswàhlen", dann auf "Speichern" klicken.





Das Funktioniert schon so im Prinzip, nur wenn ich danach erneut unter
"Standards für dieses Programm festlegen" nachsehe steht in der Reihe

Protoclos bei MAILTO ein Haken, dahinter in der Spalte steht als
Beschreibung "MailTo Protocol", in der letzten Spalte als Current
Default steht dann "Unknown Application". Dort sollte eigentlich auch
Windows Mail stehen.

Ich kann auch nicht bei der Zuordnung der Dateitypen und Protokolle
WindowsMail beim Protokoll Mailto eintragen. Im Auswahlfenster dort sehe
ich nur Thunderbird.

Ich denke hier ist irgendein EIntrag in der Windows Registry defekt.

Falls jemand Hilfe hat, wàre schön.
 

Lesen sie die antworten

#1 G.Born
07/10/2007 - 11:30 | Warnen spam
>>Öffne in der Systemsteuerung "Standardprogramme" und darin
>>auf "Standardprogramme festlegen". Klicke links unter
>>"Programme" auf "Windows Mail" und dann rechts auf
>>"Dieses Programm als Standard festlegen".
>>Klicke danach auf "Standards für dieses Programm auswàhlen"
>>und im sich daraufhin öffnenden Fenster setze ein Hàkchen
>>vor "Alle auswàhlen", dann auf "Speichern" klicken.



Normalerweise wàre der Weg, die Anwendung für das Mailto-Protokoll
festzulegen, folgender:

Startmenü -> Befehl Standardprogramme
Im Fenster Standardprogramme den Link Dateityp oder Protokoll einem Programm
zuordnen
Dann warten, bis die Zuordnungsliste aufgebaut ist, zum Eintrag für MailTo
scrollen.
Den MailTo-Eintrag markieren und die Schaltflàche Programm àndern wàhlen
Im Dialogfeld kannst Du dann die unter WIndows Vista für MailTo
registrierten Anwendungen sehen, einen Eintrag wàhlen und über die
OK-Schaltflàche dem Protokoll zuweisen.

Wenn dort keine Anwendungen mehr auftauchen, hast Du das System ziemlich
korrupiert. Dann würde ich nach einem Systemwiederherstellungspunkt *vor*
den Experimenten suchen und das System auf diesen Punkt zurücksetzen.

Die Registrierungseinstellungen sind meines Wissens nach ziemlich verstreut
in HKCR und nicht so ganz konsistent. Hier der Eintrag des
Mail-To-Protokolls:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\mailto]
"FriendlyTypeName"=hex(2):40,00,25,00,50,00,72,00,6f,00,67,00,72,00,61,00,6d,\
00,46,00,69,00,6c,00,65,00,73,00,25,00,5c,00,57,00,69,00,6e,00,64,00,6f,00,\
77,00,73,00,20,00,4d,00,61,00,69,00,6c,00,5c,00,77,00,69,00,6e,00,6d,00,61,\
00,69,00,6c,00,2e,00,65,00,78,00,65,00,2c,00,2d,00,32,00,31,00,31,00,00,00
@="URL:MailTo Protocol"
"EditFlags"=hex:02,00,00,00
"URL Protocol"=""

[HKEY_CLASSES_ROOT\mailto\DefaultIcon]
@="\"C:\\PROGRA~1\\MICROS~2\\Office12\\OUTLOOK.EXE\",7"

[HKEY_CLASSES_ROOT\mailto\shell]

[HKEY_CLASSES_ROOT\mailto\shell\open]

[HKEY_CLASSES_ROOT\mailto\shell\open\command]
@="\"C:\\PROGRA~1\\MICROS~2\\Office12\\OUTLOOK.EXE\" -c IPM.Note /m \"%1\""

Das open-Verb, obwohl vorhanden und auf Outlook zeigend wird bei mir z.B.
von Vista nicht benutzt (vermutlich, da der Standardwert auf URL:MailTo
Protocol steht.

Der Registrierungseintrag für den Maito-Handler mit dem Class-ID-Code sieht
folgendermaßen aus:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\PROTOCOLS\Handler\mailto]
"CLSID"="{3050f3DA-98B5-11CF-BB82-00AA00BDCE0B}"

Der Eintrag des Class-ID-Codes in HKCR\CLSID mit oben genanntem ID-Code
sieht dann so aus:

[HKEY_CLASSES_ROOT\CLSID\{3050f3DA-98B5-11CF-BB82-00AA00BDCE0B}\InProcServer32]
@="C:\\Windows\\system32\\mshtml.dll"
"ThreadingModel"="Apartment"

Hier ist offenbar der Windows Mail-Protokollhandler eingetragen.

Kannst ja im Registrierungseditor probieren, ob die Eintràge so vorhanden
sind und ggf. (unter Nutzung von Administratorberechtigungen) einpflegen.
Allerdings ohne Gewàhr.

Gruß

G. Born

Ähnliche fragen