WLAN auf Asus-Laptop mikt Opensuse 11.1

22/09/2009 - 12:18 von Stefan Fricke | Report spam
Hallo, ich versuche gerade WLAN ans Laufen zu kriegen. lspci meldet mir hier
folgendes:

02:00.0 Network Controller: Atheros Communications Inc. Device 002b (rev 01)

Durch Googlen bekomme ich nun raus, dass es für diesen Chip einen nativen
Treiber gibt, nàmlich das Modul ath9k, das beim Kernel der Opensuse 11.1
dabei ist. (2.6.27.29)

Den versuche ich nun ans Laufen zu kriegen. Nach dem Durchgehen einiger
Listen
zur Modulabhàngigkeit mache ich folgendes:

modprobe mac80211
modprobe ath9k

Damit sollte eigentlich alles laufen, aber iwconfig erkennt die WLAN-Karte
nicht.

Hier mal die Ausgabe von lsmod:

Module Size Used by
ath9k 328216 0
mac80211 241360 1 ath9k
cfg80211 28168 1 mac80211
rfkill 10948 0
ip6t_LOG 7180 8
xt_tcpudp 3608 6
xt_pkttype 2152 3
ipt_LOG 6812 9
xt_limit 3180 17
binfmt_misc 10100 1
autofs4 22032 0
snd_pcm_oss 48624 0
snd_mixer_oss 16808 1 snd_pcm_oss
snd_seq 61504 0
snd_seq_device 8604 1 snd_seq
i915 34376 2
drm 99248 3 i915
ip6t_REJECT 6024 3
nf_conntrack_ipv6 24712 4
ip6table_raw 2456 1
xt_NOTRACK 2152 4
ipt_REJECT 3480 3
xt_state 2568 8
iptable_raw 2760 1
iptable_filter 3400 1
ip6table_mangle 3128 0
nf_conntrack_netbios_ns 2840 0
nf_conntrack_ipv4 12808 4
nf_conntrack 80352 5
nf_conntrack_ipv6,xt_NOTRACK,xt_state,nf_conntrack_netbios_ns,nf_conntrack_ipv4
ip_tables 19464 2 iptable_raw,iptable_filter
ip6table_filter 3240 1
ip6_tables 21048 4
ip6t_LOG,ip6table_raw,ip6table_mangle,ip6table_filter
x_tables 23376 11
ip6t_LOG,xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,xt_NOTRACK,ipt_REJECT,xt_state,ip_tables,ip6_tables
ipv6 292488 31
ip6t_REJECT,nf_conntrack_ipv6,ip6table_mangle
cpufreq_conservative 8384 0
cpufreq_userspace 4204 0
cpufreq_powersave 2248 0
acpi_cpufreq 8120 0
fuse 57872 1
loop 16660 0
dm_mod 74064 0
snd_hda_intel 565156 4
uvcvideo 56512 0
video 24316 0
snd_pcm 92080 3 snd_pcm_oss,snd_hda_intel
compat_ioctl32 8520 1 uvcvideo
snd_timer 24968 2 snd_seq,snd_pcm
snd_page_alloc 9800 2 snd_hda_intel,snd_pcm
output 3672 1 video
snd_hwdep 9104 1 snd_hda_intel
rtc_cmos 13000 0
snd 73576 15
snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
rtc_core 21396 1 rtc_cmos
asus_laptop 19572 0
battery 13856 0
button 8328 0
videodev 35328 2 uvcvideo,compat_ioctl32
rtc_lib 3560 1 rtc_core
pcspkr 3064 0
sr_mod 15940 1
v4l1_compat 14220 2 uvcvideo,videodev
led_class 5008 1 asus_laptop
serio_raw 6428 0
ac 5776 0
intel_agp 30048 1
cdrom 36200 1 sr_mod
soundcore 8368 1 snd
atl1e 39788 0
sg 35376 0
sd_mod 35272 4
crc_t10dif 2152 1 sd_mod
ehci_hcd 54676 0
uhci_hcd 26840 0
usbcore 195712 4 uvcvideo,ehci_hcd,uhci_hcd
edd 10272 0
ext3 140824 2
mbcache 9484 1 ext3
jbd 61752 1 ext3
fan 6016 0
ahci 34612 4
libata 183696 1 ahci
scsi_mod 178888 4 sr_mod,sg,sd_mod,libata
dock 14212 1 libata
thermal 24408 0
processor 49424 4 acpi_cpufreq,thermal
thermal_sys 14336 4 video,fan,thermal,processor
hwmon 3720 1 thermal_sys

Fehlt da noch was?

Stefan
 

Lesen sie die antworten

#1 Stefan Fricke
22/09/2009 - 15:26 | Warnen spam
Kleine Ergànzung: Der Chip wird zwar erkannt, aber nicht als WLAN.

hwinfo --wlan bleibt leer.
hwinfo --network liefert mir folgendes:
26: PCI 200.0: 0280 Network controller
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_168c_2b
Unique ID: B35A.YOgHHBQ2is7
Parent ID: qTvu.8Makl3iDVc3
SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:02:00.0
SysFS BusID: 0000:02:00.0
Hardware Class: network
Model: "Atheros Network controller"
Vendor: pci 0x168c "Atheros Communications Inc."
Device: pci 0x002b
SubVendor: pci 0x1a3b
SubDevice: pci 0x1089
Revision: 0x01
Memory Range: 0xfeaf0000-0xfeafffff (rw,non-prefetchable)
IRQ: 5 (no events)
Module Alias: "pci:v0000168Cd0000002Bsv00001A3Bsd00001089bc02sc80i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #17 (PCI bridge)

Was tun?

Ähnliche fragen