WLAN-Geschwindigkeitsproblem

07/04/2012 - 03:44 von Gerald Breuer | Report spam
Hallo!

Ich habe hier folgendes Problem:
Ich nutze mein WLAN sowohl bei mir zu Hause als auch im Büro ein
Haus weiter; auf jeder Seite sitzt ein PC im LAN. Die beiden LANs
habe ich mit zwei Accesspoints vom Typ TP-Link TL-WA901ND verbunden.
Einer arbeitet als Accesspoint und ein anderer als Client. Die WLAN
-Parameter sind:
- Region: Germany
- Channel: Auto
- Channel Width: 20/40MHz
- Max Tx Rate: 300Mbps
- Verschlüsselung ist WPA2-PSK mit AES
- Beacon Interval: 100
- RTS Threshold: 2346
- Fragmentation Threshold: 2346
- DTIM Interval: 1
- "Enable WMM" ist angeschaltet
- "Enable Short GI" ist auch angeschaltet
- "Enable AP Isolation" ist auch angeschaltet
Der Accesspoint der als solcher arbeitet - im folgenden AP genannt
- steht hinter einem Fenster und von dort aus kann man auf die Mauer
des Hauses schauen hinter der der "Accesspoint" steht der als Client
- im folgenden C genannt - arbeitet.
Nun zu meinem Problem:
Wenn ich Daten von einem PC der an C angebunden ist zu einem PC
der an AP angebunden ist übertrage, dann bekomme ich acht bis 10
MB/s egal ob ich das mit netio oder iperf tue und auch egal ob
ich das mit tcp oder udp teste; auch das Kopieren einer Datei
über den Windows Explorer fàllt in den selben Bereich bzgl. des
Durchsatzes. Übertrage ich aber Daten von einem PC der an AP an-
gebunden ist an einen PC der an C angebunden ist mittels genann-
ter Methoden, dann liegt der Durchsatz für alle genannten Metho-
den bei 0,8MB/s bis 1,3MB/s. Und genau diese Richung ist für mich
die wichtigere. Aufgrund der Unabhàngigkeit des Problems vom Pro-
tokoll meine ich, dass es sich hier um ein Layer-2-Problem han-
deln muss.
Kann mir hier jemand weiterhelfen?
 

Lesen sie die antworten

#1 Bastian Lutz
07/04/2012 - 14:33 | Warnen spam
Hallo Gerald!

Am 07.04.2012 03:44, schrieb Gerald Breuer:

[...]

Wenn ich Daten von einem PC der an C angebunden ist zu einem PC
der an AP angebunden ist übertrage, dann bekomme ich acht bis 10
MB/s egal ob ich das mit netio oder iperf tue und auch egal ob
ich das mit tcp oder udp teste; auch das Kopieren einer Datei
über den Windows Explorer fàllt in den selben Bereich bzgl. des
Durchsatzes. Übertrage ich aber Daten von einem PC der an AP an-
gebunden ist an einen PC der an C angebunden ist mittels genann-
ter Methoden, dann liegt der Durchsatz für alle genannten Metho-
den bei 0,8MB/s bis 1,3MB/s. Und genau diese Richung ist für mich
die wichtigere. Aufgrund der Unabhàngigkeit des Problems vom Pro-
tokoll meine ich, dass es sich hier um ein Layer-2-Problem han-
deln muss.
Kann mir hier jemand weiterhelfen?



Ich weiss nicht, ob ich es richtig verstanden habe. Kannst du zur
Sicherheit evtl. ein einfaches JPEG- oder PNG-Bildchen erstellen mit
einem Ueberblick ueber die Hardware und mit Pfeilen oder so andeuten, in
welcher Situation die Datenrate so mies ist und dann irgendwo ins Web
hochladen und hier verlinken?

Hm, kann da trotz deiner sehr ausfuehrlichen Angaben nur meine Glaskugel
befragen:
- Sicher, dass es nicht einfach daran liegen kann, dass die wohl relativ
lange Funkverbindung mies ist? (Fensterscheiben, zu kleine Antennen,
viele Stoersender (in dem Bereich funkt ja noch viel mehr als WLAN)
- Firmware-Update der beteiligten AP?
- Sind irgendwo QOS-Einstellungen im Spiel? Irgendwo vermurkste
Paketgrößen auf IP-Ebene eingestellt? (um was derartiges auf OS-Ebene
auszuschliessen, sollte es reichen, irgend ein Live-Linux zu booten)

HTH

Bastian Lutz

Wenn jemand irgendwas von Anonymitaet faselt, wenn er oder jemand
anderes (meist Newbies) darauf hingewiesen wurde, dass er einen Realname
verwenden sollte, hat er den Hinweis nicht richtig gelesen.

Ähnliche fragen