Forums Neueste Beiträge
 

Wo Assembly speichern

25/08/2009 - 12:12 von Frank Müßner | Report spam
Hallo,

ich habe eine kleine ASP Applikation auf meinen eigenen Webserver laufen.
Jetzt binde ich ein fremdes Assembly ein. Làuft auf dem Entwickler Rechner
problemlos.
Für die Serverinstallation dachte ich das es ausreicht alles 1:1 zu
kopieren, bekomme aber beim Aufruf der Site:

Ausnahmedetails: System.IO.FileNotFoundException: Das angegebene Modul wurde
nicht gefunden. (Ausnahme von HRESULT: 0x8007007E)
...
Stapelüberwachung:
[FileNotFoundException: Das angegebene Modul wurde nicht gefunden. (Ausnahme
von HRESULT: 0x8007007E)]
System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase,
Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark,
Boolean throwOnFileNotFound, Boolean forIntrospection) +0
System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase,
Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark,
Boolean throwOnFileNotFound, Boolean forIntrospection) +43
System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef,
Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean
forIntrospection) +127
System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence
assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection) +142
System.Reflection.Assembly.Load(String assemblyString) +28
System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String
assemblyName, Boolean starDirective) +46


Der Fehler besagt das eine Datei nicht gefunden werden kann. Wo wird
eingestellt wo nach gesucht wird? Welche Datei wurde gesucht?

Güße Frank
 

Lesen sie die antworten

#1 Frank Muessner
25/08/2009 - 13:41 | Warnen spam
Sorry, hat sich erledigt.
Das Problem war eine msvcm90.dll in dem BIN Verzeichnis. Die das verursacht
hat.

Grüße Frank



"Frank Müßner" schrieb im Newsbeitrag
news:
Hallo,

ich habe eine kleine ASP Applikation auf meinen eigenen Webserver laufen.
Jetzt binde ich ein fremdes Assembly ein. Làuft auf dem Entwickler Rechner
problemlos.
Für die Serverinstallation dachte ich das es ausreicht alles 1:1 zu
kopieren, bekomme aber beim Aufruf der Site:

Ausnahmedetails: System.IO.FileNotFoundException: Das angegebene Modul
wurde nicht gefunden. (Ausnahme von HRESULT: 0x8007007E)
...
Stapelüberwachung:
[FileNotFoundException: Das angegebene Modul wurde nicht gefunden.
(Ausnahme von HRESULT: 0x8007007E)]
System.Reflection.Assembly._nLoad(AssemblyName fileName, String
codeBase, Evidence assemblySecurity, Assembly locationHint,
StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean
forIntrospection) +0
System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase,
Evidence assemblySecurity, Assembly locationHint, StackCrawlMark&
stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection) +43
System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef,
Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean
forIntrospection) +127
System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence
assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
+142
System.Reflection.Assembly.Load(String assemblyString) +28
System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String
assemblyName, Boolean starDirective) +46


Der Fehler besagt das eine Datei nicht gefunden werden kann. Wo wird
eingestellt wo nach gesucht wird? Welche Datei wurde gesucht?

Güße Frank





Ähnliche fragen