wo wird SSL-Serverflag f

12/11/2008 - 14:16 von Werner P. Schulz | Report spam
Unter Debian Etch ganz simpel zu installieren - unter openSUSE 10.3 ein
frustrierender Kampf. Ich bekomme https unter Apache2 nicht zum Laufen.
Bisher habe ich so ziemlich alles gegoogelt zu diesem Thema. Zur Zeit habe
ich gefunden, daß bei Suse in /etc/sysconfig/apache2
APACHE_SERVER_FLAGS="SSL" gesetzt und mit SuSEconfig aktiviert werden
muß. Anschliessend apache2ctl restart.

Dieser geànderte Eintrag müßte jetzt in
/etc/apache2/sysconfig.d/global.conf erscheinen - tut es aber nicht und
demnach bekomme ich beim Versuch einer https-Verbindung immer nur die
Meldung, daß keine Verbindung besteht. Die Eintràge im error-log führen
mich auch nicht weiter.


[Wed Nov 12 13:56:09 2008] [notice] suEXEC mechanism enabled
(wrapper: /usr/sbin/suexec2)
[Wed Nov 12 13:56:09 2008] [info] Init: Seeding PRNG with
0 bytes of entropy
[Wed Nov 12 13:56:09 2008] [info] Init: Generating temporary
RSA private keys (512/1024 bits)
[Wed Nov 12 13:56:09 2008] [info] Init: Generating temporary
DH parameters (512/1024 bits)
[Wed Nov 12 13:56:09 2008] [warn] Init: Session Cache is not
configured [hint: SSLSessionCache]
[Wed Nov 12 13:56:09 2008] [info] Init: Initializing (virtual)
servers for SSL
[Wed Nov 12 13:56:09 2008] [info] Server: Apache/2.2.4, Interface:
mod_ssl/2.2.4, Library: OpenSSL/0.9.8e
[Wed Nov 12 13:56:09 2008] [info] Init: Seeding PRNG with
0 bytes of entropy
[Wed Nov 12 13:56:09 2008] [info] Init: Generating temporary
RSA private keys (512/1024 bits)
[Wed Nov 12 13:56:09 2008] [info] Init: Generating temporary
DH parameters (512/1024 bits)
[Wed Nov 12 13:56:09 2008] [info] Init: Initializing
(virtual) servers for SSL
[Wed Nov 12 13:56:09 2008] [info] Server: Apache/2.2.4,
Interface: mod_ssl/2.2.4, Library: OpenSSL/0.9.8e
[Wed Nov 12 13:56:09 2008] [notice] Apache/2.2.4
(Linux/SUSE) mod_ssl/2.2.4 OpenSSL/0.9.8e
configured -- resuming normal operations
[Wed Nov 12 13:56:09 2008] [info] Server built:
Sep 25 2008 11:52:17 [Wed
Nov 12 13:56:09 2008] [debug] prefork.c(991):
AcceptMutex: sysvsem (default: sysvsem)

Gruss Werner
mail nur an => nospam0601 at wp-schulz.de

Google fuer Linux-Fragen => http://www.google.de/linux <=
 

Lesen sie die antworten

#1 Andreas Kilgus
12/11/2008 - 14:28 | Warnen spam
Werner P. Schulz schrieb:

Unter Debian Etch ganz simpel zu installieren - unter openSUSE 10.3 ein
frustrierender Kampf. Ich bekomme https unter Apache2 nicht zum Laufen.
Bisher habe ich so ziemlich alles gegoogelt zu diesem Thema. Zur Zeit habe
ich gefunden, daß bei Suse in /etc/sysconfig/apache2
APACHE_SERVER_FLAGS="SSL" gesetzt und mit SuSEconfig aktiviert werden
muß. Anschliessend apache2ctl restart.

Dieser geànderte Eintrag müßte jetzt in
/etc/apache2/sysconfig.d/global.conf erscheinen - tut es aber nicht



Aus genannter Datei: "Files in this directory are created at apache start
time by /usr/sbin/rcapache2". Von apache2ctl steht da nix.

Gruß
Andi
E-Mails an die Absender-Adresse werden nicht gelesen.

Ähnliche fragen