WORD2003: Datypen von Textformularfeldern werden u. U. nicht geprueft - Bug?

26/06/2010 - 11:07 von Jens Kleinschmidt | Report spam
Hallo NG,

Ausgangspunkt ist ein WORD-Formular mit einem Textformularfeld vom Typ
"Datum"; Das Dokument ist geschützt mit der Option "Ausfüllen von
Formularen"

Beobachtung: Erfolgt im Textformularfeld eine ungültige Eingabe (d. h.
also eine Nicht-Datum-Eingabe) und wird anschließend (d. h. zum
Verlassen des Felds) auf eine leere Stelle des Formulars geklickt, so
erscheint (auch beim anschließenden Anklicken eines anderen Felds)
keine Fehlermeldung wegen der unzulàssigen Eingabe. Auf diese Weise
kann der User offenbar die Fehlermeldung endgültig unterdrücken.

Spring der User dagegen mit TAB in das nàchste Feld oder klickt mit
der Maus DIREKT ein anderes Feld an, so erscheint die o. g.
Fehlermeldung wie erwartet.

Ist das ein Bug in WORD? Müsste die Fehlermeldung nicht beim verlieren
des Fokus (auf jede erdenkliche Art) erscheinen?

Wie kann man dieses Problem umgehen?

Gruß
Jens
 

Lesen sie die antworten

#1 Bernhard Sander
28/06/2010 - 13:59 | Warnen spam
Hallo Jens,

Ausgangspunkt ist ein WORD-Formular mit einem Textformularfeld vom Typ
"Datum"; Das Dokument ist geschützt mit der Option "Ausfüllen von
Formularen"

Beobachtung: Erfolgt im Textformularfeld eine ungültige Eingabe (d. h.
also eine Nicht-Datum-Eingabe) und wird anschließend (d. h. zum
Verlassen des Felds) auf eine leere Stelle des Formulars geklickt, so
erscheint (auch beim anschließenden Anklicken eines anderen Felds)
keine Fehlermeldung wegen der unzulàssigen Eingabe. Auf diese Weise
kann der User offenbar die Fehlermeldung endgültig unterdrücken.

Spring der User dagegen mit TAB in das nàchste Feld oder klickt mit
der Maus DIREKT ein anderes Feld an, so erscheint die o. g.
Fehlermeldung wie erwartet.

Ist das ein Bug in WORD? Müsste die Fehlermeldung nicht beim verlieren
des Fokus (auf jede erdenkliche Art) erscheinen?

Wie kann man dieses Problem umgehen?


Das ist eine sehr làstige Làstigkeit von Word und schon seit mehreren Versionen
leider so der Fall.

Das Problem besteht in gleicher Weise, wenn man Formularfelder mit Makros
verbindet. Die werden auch nicht sicher ausgeführt, wenn man mit der Maus das
Feld verlàsst.

Abhilfe: ich kenne keine.

Gruß
Bernhard Sander

Ähnliche fragen