workaround: Matrixformel bezieht sich auf Zellen mit Formel

04/09/2009 - 14:07 von Marco | Report spam
Hallo NG,

Ich habe eine Tabelle, in der ich mit Hilfe einer Matrixformel
klassisch die Zeilenprodukte zweier Spalten addiere

{=summe($A$5:$A$80*B$5:B$80)}

Jetzt gibt es eine Spalte C in der die Werte auf Basis der Spalte B
berechnet sind.
Ich hàtte jetzt gerne die Formel:

{=summe($A$5:$A$80*C$5:C$80)}

Das ergibt aber den #WERT-Fehler, weil in den Zellen in Spalte C eine
Formel drinsteht.

Excelhilfe:
"Matrixkonstanten können keine Zellbezüge, Spalten oder Zeilen
ungleicher Lànge, Formeln oder die Sonderzeichen $ (Dollarzeichen),
Klammern oder % (Prozentzeichen) enthalten."

Gibt es hier einen Workaround, der mir das gewünschte ERgebnis bringt?

Ich benutze Excel 2003 SP3

Dank euch und beste Grüsse

Marco
 

Lesen sie die antworten

#1 Alexander Wolff
04/09/2009 - 14:18 | Warnen spam
Die Tastatur von Marco wurde wie folgt gedrückt:
Ich hàtte jetzt gerne die Formel:

{=summe($A$5:$A$80*C$5:C$80)}



=SUMMENPRODUKT($A$5:$A$80*C$5:C$80) wàre das gleiche.
=SUMMENPRODUKT($A$5:$A$80;C$5:C$80) wàre 10% schneller (wenn es geht).

Das ergibt aber den #WERT-Fehler, weil in den Zellen in Spalte C eine
Formel drinsteht.



Die Begründung ist falsch. Formel oder nur Wert ist egal; worauf es ankommt,
ist, dass der Inhalt rechenbar ist, also eine Zahl/Datum/Wahrheitswert
ergibt oder ist. Keinen Text!

Excelhilfe:
"Matrixkonstanten können keine Zellbezüge, Spalten oder Zeilen
ungleicher Lànge, Formeln oder die Sonderzeichen $ (Dollarzeichen),
Klammern oder % (Prozentzeichen) enthalten."



Eine Matrixkonstante sieht z.B. so aus: {1;2;3}. Du hast eine MatrixFORMEL.

Gibt es hier einen Workaround, der mir das gewünschte ERgebnis bringt?



Darauf achten, dass nur Zahlen in C:C möglich sind.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen