[Writer 2.4.1: StarBasic] Drucken mehrerer Seiten: Bug?

07/10/2008 - 12:12 von Werner Pilwousek | Report spam
Hallo,

folgender Code hat zum Drucken von 2 Seiten bis Version 2.3 klaglos
funktioniert:
###################
Sub Print2
Dim mPrintopts(0) As New com.sun.star.beans.PropertyValue

oDocument = ThisComponent()

mPrintOpts(0).Name = "CopyCount"
mPrintOpts(0).Value = 2

oDocument.Print mPrintOpts()
End Sub
###################
(Eine analoge Funktion ist auch für 4 Seiten im Einsatz.)

Seit Version 2.4.x (aktuell 2.4.1) BS Vista gibt es folgendes Problem: Es
werden nun doppelt so viele Seiten gedruckt.
Bug oder Einbau eines neues Feature das ich nicht kenne?
Im Einsatz ist das Makro an einem HP 2605dn im Duplexmodus. Aber auch bei
einem PDF-Drucker (Papier ist zum Testen einfach zu teuer ;-) ) gibt's
dieses Phànomen.

Mich würden nun interessieren: Tritt das auch bei Euch auf? Ist es auch so
bei der neuen Version 3.0 beta etc.


By The Way: Gibt es eine Möglichkeit dem Drucker beizubringen, dass die mit
Makro gedruckte (mehrere) Seiten im Duplexmodus ausgibt, ohne jedesmal in
die Druckereinstellungen zu gehen? Früher hat sich die Dokumentvorlage die
Druckereinstellungen gemerkt.

Schönen Gruß
Werner
 

Lesen sie die antworten

#1 Mathias Bauer
12/10/2008 - 15:49 | Warnen spam
"Werner Pilwousek" schrieb :

Hallo,

folgender Code hat zum Drucken von 2 Seiten bis Version 2.3 klaglos
funktioniert:
###################
Sub Print2
Dim mPrintopts(0) As New com.sun.star.beans.PropertyValue

oDocument = ThisComponent()

mPrintOpts(0).Name = "CopyCount"
mPrintOpts(0).Value = 2

oDocument.Print mPrintOpts()
End Sub
###################
(Eine analoge Funktion ist auch für 4 Seiten im Einsatz.)

Seit Version 2.4.x (aktuell 2.4.1) BS Vista gibt es folgendes Problem: Es
werden nun doppelt so viele Seiten gedruckt.
Bug oder Einbau eines neues Feature das ich nicht kenne?
Im Einsatz ist das Makro an einem HP 2605dn im Duplexmodus. Aber auch bei
einem PDF-Drucker (Papier ist zum Testen einfach zu teuer ;-) ) gibt's
dieses Phànomen.

Mich würden nun interessieren: Tritt das auch bei Euch auf? Ist es auch so
bei der neuen Version 3.0 beta etc.



Das ist ein Bug, der voraussichtlich in der Version 3.1 behoben sein
wird:

http://www.openoffice.org/issues/show_bug.cgi?idˆ333

Ciao,
Mathias

Ähnliche fragen