WSUS Client Problem

14/11/2007 - 16:00 von André Heublein | Report spam
Hallo *,

auf einem W2k3Sp1 X64 Server làuft nebenbei WSUS3, neu installiert, neben
einem SQL2005 x64.

Nun werden Clients (WinXPSp2x86) , die (noch) nicht in der AD-Domàne sind,
manuell per Registrierungseintràge auf diesen Server verwiesen.
Ein Update ist jedoch nicht möglich, folgende Fehlermeldung erscheint im
Windowsupdate.log (nach einem wuauclt /detectnow):


007-11-14 14:35:35:078 1060 4e0 PT +++++++++++ PT: Synchronizing server
updates +++++++++++
2007-11-14 14:35:35:078 1060 4e0 PT + ServiceId =
{3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL =
http://10.10.10.191/ClientWebService/client.asmx
2007-11-14 14:35:35:078 1060 4e0 PT WARNING: GetConfig failure, error =
0x80244019, soap client error = 10, soap error code = 0, HTTP status code =
404
2007-11-14 14:35:35:078 1060 4e0 PT WARNING: PTError: 0x80244019
2007-11-14 14:35:35:078 1060 4e0 PT WARNING: GetConfig_WithRecovery failed:
0x80244019
2007-11-14 14:35:35:078 1060 4e0 PT WARNING: RefreshConfig failed:
0x80244019
2007-11-14 14:35:35:078 1060 4e0 PT WARNING: RefreshPTState failed:
0x80244019
2007-11-14 14:35:35:078 1060 4e0 PT WARNING: Sync of Updates: 0x80244019
2007-11-14 14:35:35:078 1060 4e0 PT WARNING: SyncServerUpdatesInternal
failed: 0x80244019
2007-11-14 14:35:35:078 1060 4e0 Agent * WARNING: Failed to synchronize,
error = 0x80244019
2007-11-14 14:35:35:078 1060 4e0 Agent * WARNING: Exit code = 0x80244019


Schaue ich mir die Filestruktur auf dem Server an, sehe ich dort keine
client.asmx , die aufgrufen werden könnte.

Suche ich nach einer client.asmx, finde ich diese in folgenden Verzeichnis:

C:\Programme\Update Services\WebServices\dssauthwebservice
Hier sind auch wesentlich mehr Dateien zu finden, unter anderem ein
Verzeichnis bin.

Mein derzeitiges virtuelles IIS-Verzeichnis ClientWebService zeigt jedoch
auf:
C:\Programme\Update Services\WebServices\ClientWebServiceM5.
Hier liegt auch nur eine SuSServerVersion.xml drin.

Setze ich das virtuelle Verzeichnis auf das wohl richtige, taucht folgende
Fehlermeldung im Clientlog auf:

+ ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL =
http://10.10.10.191/ClientWebService/client.asmx
2007-11-14 15:48:09:953 1072 53c PT WARNING: GetConfig failure, error =
0x80244008, soap client error = 8, soap error code = 0, HTTP status code =
200
2007-11-14 15:48:09:953 1072 53c PT WARNING: PTError: 0x80244008
2007-11-14 15:48:09:953 1072 53c PT WARNING: GetConfig_WithRecovery failed:
0x80244008
2007-11-14 15:48:09:953 1072 53c PT WARNING: RefreshConfig failed:
0x80244008
2007-11-14 15:48:09:953 1072 53c PT WARNING: RefreshPTState failed:
0x80244008
2007-11-14 15:48:09:953 1072 53c PT WARNING: Sync of Updates: 0x80244008
2007-11-14 15:48:09:953 1072 53c PT WARNING: SyncServerUpdatesInternal
failed: 0x80244008
2007-11-14 15:48:09:953 1072 53c Agent * WARNING: Failed to synchronize,
error = 0x80244008
2007-11-14 15:48:09:953 1072 53c Agent * WARNING: Exit code = 0x80244008
2007-11-14 15:48:09:953 1072 53c Agent *********
2007-11-14 15:48:09:953 1072 53c Agent ** END ** Agent: Finding updates
[CallerId = AutomaticUpdates]
2007-11-14 15:48:09:953 1072 53c Agent *************
2007-11-14 15:48:09:953 1072 53c Agent WARNING: WU client failed Searching
for update with error 0x80244008
2007-11-14 15:48:09:953 1072 918 AU >>## RESUMED ## AU: Search for updates
[CallId = {40B841FE-CC66-4945-BFB7-C8572E81414D}]
2007-11-14 15:48:09:953 1072 918 AU # WARNING: Search callback failed,
result = 0x80244008
2007-11-14 15:48:09:953 1072 918 AU # WARNING: Failed to find updates with
error code 80244008
2007-11-14 15:48:09:953 1072 918 AU #########
2007-11-14 15:48:09:953 1072 918 AU ## END ## AU: Search for updates
[CallId = {40B841FE-CC66-4945-BFB7-C8572E81414D}]
2007-11-14 15:48:09:953 1072 918 AU #############


Zu diesem fehler finde ich zwar einen Haufen Hinweise und Fehlermeldungen,
jedoch bisher keine für mich passende Lösung.
Hier die bereits durchgeführten Arbeiten:

Überprüfung der Berechtigungen auf dem IIS-Verzeichnis
Installation des WSUS3 Agents auf dem Client
Löschung SoftwareDistribution Verzeichnis auf Client
Start PC - wuauclt /resetauthorization /detectnow


Kann mir bitte jemand noch einen Hinweis geben oder gar die Lösung dieses
Problems darle´gen?

Vielen Dank schon mal im voraus

André
 

Lesen sie die antworten

#1 André Heublein
14/11/2007 - 18:11 | Warnen spam
Nochmaliger Hinweis:
W2k3 R2 Sp2 Server in x64; Die Installation des WSUS wurde auch mit dem x64
Paket vorgenommen.
Fehlt im x64 Paket vom .Net2 ein Paket?

Als Nachtrag eine Ausgabe des wsusdebugtool:

C:\Temp>WsusDebugTool.exe

Unbehandelte Ausnahme: System.IO.FileNotFoundException: Die Datei oder
Assembly
Microsoft.UpdateServices.Common, Version=2.0.0.0, Culture=neutral,
PublicKeyToke
n1bf3856ad364e35 oder eine Abhàngigkeit davon wurde nicht gefunden. Das
System
kann die angegebene Datei nicht finden.
Dateiname: Microsoft.UpdateServices.Common, Version=2.0.0.0,
Culture=neutral, Pu
blicKeyToken1bf3856ad364e35
bei Microsoft.SoftwareDistribution.Tools.SusServerTool.Main(String[]
args)

Zustandsinformationen vor Bindung ==LOG: Benutzer = domàne\administrator1
LOG: DisplayName = Microsoft.UpdateServices.Common, Version=2.0.0.0,
Culture=neu
tral, PublicKeyToken1bf3856ad364e35
(Fully-specified)
LOG: Appbase = file:///C:/Temp/
LOG: Ursprünglicher PrivatePath = NULL
Aufruf von Assembly : WsusDebugTool, Version=0.0.0.0, Culture=neutral,
PublicKey
Token=null.
==LOG: Diese Bindung startet im default-Load-Kontext.
LOG: Es wurde keine Anwendungskonfigurationsdatei gefunden.
LOG: Die Computerkonfigurationsdatei von
C:\WINOS\Microsoft.NET\Framework\v2.0.5
0727\config\machine.config wird verwendet.
LOG: Verweis nach der Richtlinie: Microsoft.UpdateServices.Common,
Version=2.0.0
.0, Culture=neutral, PublicKeyToken1bf3856ad364e35
LOG: Download von neuem URL
file:///C:/Temp/Microsoft.UpdateServices.Common.DLL.

LOG: Download von neuem URL
file:///C:/Temp/Microsoft.UpdateServices.Common/Micr
osoft.UpdateServices.Common.DLL.
LOG: Download von neuem URL
file:///C:/Temp/Microsoft.UpdateServices.Common.EXE.

LOG: Download von neuem URL
file:///C:/Temp/Microsoft.UpdateServices.Common/Micr
osoft.UpdateServices.Common.EXE.



Hier noch eine Ausgabe, wenn ich die Datei
http://10.10.10.191/ClientWebService/client.asmx
im IE auf dem Server aufrufe:



Serverfehler in der Anwendung /.


Konfigurationsfehler
Beschreibung: Fehler beim Verarbeiten einer Konfigurationsdatei, die für
diese Anforderung erforderlich ist. Überprüfen Sie die unten angegebenen
Fehlerinformationen, und àndern Sie die Konfigurationsdatei entsprechend.

Parserfehlermeldung: Einen Abschnitt, der als
allowDefinition='MachineToApplication' registriert ist, über die
Programmebene hinaus zu verwenden verursacht einen Fehler. Dieser Fehler
kann von einem virtuellen Verzeichnis verursacht werden, das nicht als
Anwendung in IIS konfiguriert ist.

Quellfehler:

Zeile 38:
Zeile 39:
Zeile 40: <authentication mode="Windows" />
Zeile 41:
Zeile 42: <authorization>


Quelldatei: C:\Programme\Update
Services\WebServices\clientwebservice\web.config Zeile: 40


Weitere Konfigurationsfehler anzeigen:

Einen Abschnitt, der als allowDefinition='MachineToApplication' registriert
ist, über die Programmebene hinaus zu verwenden verursacht einen Fehler.
Dieser Fehler kann von einem virtuellen Verzeichnis verursacht werden, das
nicht als Anwendung in IIS konfiguriert ist. (C:\Programme\Update
Services\WebServices\clientwebservice\web.config line 69)


Versionsinformationen: Microsoft .NET Framework-Version:2.0.50727.832;
ASP.NET-Version:2.0.50727.832


Wenn ich die Info?s richtig verstehe, ist entweder das virtuelle Verzeichnis
im IIS nicht als Anwendung konfiguriert oder aber die Einstellungen in der
web.config sind schon systemweit vorgegeben und können nicht nochmal hier im
Unterverzeichnis gesetzt werden.


Ich hoffe, diese Info?s helfen weiter.

Bis dann

André

Ähnliche fragen