X.org 7.3 kein untrusted-Zugriff mehr

11/02/2008 - 00:10 von L. Kliemann | Report spam
Ich arbeite sehr viel mit untrusted-Verbindungen, d.h. ich wechsel die
User-ID und nehme dabei ein mit xauth erzeugtes Cookie mit, welches nur den
sog. untrusted-Zugriff erlaubt (was bei xauth übrigens default ist).

Das hat unter X.org 6.9.0 wunderbar funktioniert.

Nun musste ich auf ein neueres X.org aktualisieren und bin gleich auf die
neueste, d.h. 7.3 gegangen. Noch total begeistert von dem neuen xrandr musste
ich leider feststellen, dass der untrusted-Zugriff nicht mehr geht!

Es kommt, egal welches Programm ich starte, die Meldung:

X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 55 (X_CreateGC)
Resource id in failed request: 0x58
Serial number of failed request: 1
Current serial number in output stream: 4

Was hat sich da bloß veràndert?

Gibt es noch eine Stelle, wo man dieses Feature einschalten muss?

System ist ein LFS, also alles selbst kompiliert. Vielleicht liegt es auch an
einem ./configure-Schalter; aber bei welchem der 300 Module fange ich an zu
suchen?

Danke für Hinweise!
Lasse
 

Lesen sie die antworten

#1 L. Kliemann
13/02/2008 - 00:35 | Warnen spam
* L. Kliemann :

[ X.org 7.3 ]

Es kommt, egal welches Programm ich starte, die Meldung:

X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 55 (X_CreateGC)
Resource id in failed request: 0x58
Serial number of failed request: 1
Current serial number in output stream: 4



Das Problem stellte sich als ausgesprochen hartnàckig heraus. Trotz
tagelangem Herumprobieren und stundenlanger Webrecherche habe ich *keine*
Lösung für 7.3 gefunden. Nun habe ich in meiner Verzweiflung auf 7.2
umgestellt, und damit funktioniert es.

Es handelt sich also offenbar um eine Verànderung, die zwischen 7.2 und 7.3
passiert ist, möglicherweise im Bereich der Security-Erweiterung. Ich werde
das in kürze an offizieller Stelle als Fehlerbericht einreichen. Denn an
einen Bedien- oder Compile-Fehler glaube ich nicht mehr. Das 7.2, womit es
jetzt geht, làuft mit praktisch denselben Einstellungen und wurde in ganz
àhnlichem Verfahren kompiliert.

Ähnliche fragen