Xen auf und mit Debian etch: Netzwerkprobleme ab dem dritten Gast

08/04/2008 - 22:47 von Martin Mustermann | Report spam
Hallo,

auf einem Server, der über eth0 direkt am Netz hàngt, làuft Debian Etch
und die in dieser Distribution enthaltenen xen-Pakete sowie einige
weitere Debian Etch - Installationen als Gàste.

Seit einem Reboot habe ich dort das (auch nach weiteren Reboots
bleibende) Problem, dass keine Verbindungen nach aussen mehr aus
Gastmaschinen heraus klappen, wenn diese als dritte, vierte usw.
gestartet wurden.

Kennt jemand das Problem und hat vielleicht einen Tipp für mich?

Die jeweils zuerst gestarteten zwei Gàste machen keinerlei Probleme.
Ebenso wenig der physikalische Host.
Auch bei Netzwerkverkehr untereinander sowie zum physikalischen Host
gibt es keinerlei Probleme.

Setup des Gastgebers ist Folgendes:
eth0 ganz normal im /etc/interfaces eingestellt sowie in xend-config.sxp:
(network-script network-bridge)
(vif-script vif-bridge)

Habe auch schon daran gedacht, dass im Rechenzentrum irgendwelche
ARP-Caches Probleme machen oder eine neue (weil bis dato nix nach
Reboots passierte) Sicherheitseinstellung vielleicht was gesperrt hat,
weil beim Starten der Gàste, von denen jeder eine statische IP hat diese
ja neue (und weil bis dato noch nicht in der Gastconfig eingestellt
zufàllige) MAC-Adressen bekamen. Diese sind nun fest. Gegen diese
Vermutungen spricht jedoch, dass nach Reboot jede der Gastumgebungen für
sich, aber weiterhin also nur die zwei zuerst gestarteten jedoch auch
mit den nun neuen MAC-Adressen funktionieren.

Hat jemand eine irgendeine Idee oder einen Link, den ich bisher nicht
gefunden habe?

Gruesse,
Martin
 

Lesen sie die antworten

#1 E. Braun
09/04/2008 - 08:40 | Warnen spam
Martin Mustermann wrote:

auf einem Server, der über eth0 direkt am Netz hàngt, làuft Debian Etch
und die in dieser Distribution enthaltenen xen-Pakete sowie einige
weitere Debian Etch - Installationen als Gàste.

Seit einem Reboot habe ich dort das (auch nach weiteren Reboots
bleibende) Problem, dass keine Verbindungen nach aussen mehr aus
Gastmaschinen heraus klappen, wenn diese als dritte, vierte usw.
gestartet wurden.


[...]

Das Problem kommt mir bekannt vor. Grund war eine Beschrànkung der
MAC-Adressen am Switchport. Nach dem "Ethernet-Link-Up" merkte sich der
zugeordnete Switchport eine begrenzte Anzahl MAC-Adressen, deren Pakete
passieren durften. Von jeder weiteren MAC-Adresse wurden deren Pakete
verworfen. Nach einem kurzzeitigen Abstöpseln des Netzwerkkabels wurde
wieder von vorn gezàhlt, d. h. daß dann wieder die ersten N Gàste eine
Verbindung bekamen, was aber nicht die gleichen wie vor dem Ziehen des
Kabels sein mußten.
Teste dieses Verhalten einmal bei Dir (ist ja recht einfach zu
bewerkstelligen und ein sicheres Indiz), vielleicht ist die Ursache ja die
gleiche.

Gruß,

Ähnliche fragen