Xen und WLAN?

16/01/2009 - 21:02 von Uwe Premer | Report spam
So, habe inzwischen dochmal Xen installiert.
Xen ist auch schon im Grub-Menü startbar eingetragen, Laptop startet
auch schön mit Xen.
Zuerst habe ich auch ca. für 2 Minuten den normalen Internet-Zugang via
WLAN, aber reproduzierbar ist WLAN nach 2 Minuten nicht mehr
erreichbar, wenn ich dann das WLAN deaktiviere und anschliessend wieder
aktiviere, ist mein Router nicht mehr erreichbar und es làßt sich keine
Verbindung mehr aufbauen.

Starte ich dagegen die SUSE (11.0/64-Bit) ohne Xen, habe ich, so lange
ich will, einen funktionierenden WLAN-Zugang.

Was làuft da flscha?
Uwe
 

Lesen sie die antworten

#1 Günther Schwarz
16/01/2009 - 22:29 | Warnen spam
Uwe Premer hatte geschrieben:

So, habe inzwischen dochmal Xen installiert.
Xen ist auch schon im Grub-Menü startbar eingetragen, Laptop startet
auch schön mit Xen.
Zuerst habe ich auch ca. für 2 Minuten den normalen Internet-Zugang
via WLAN, aber reproduzierbar ist WLAN nach 2 Minuten nicht mehr
erreichbar, wenn ich dann das WLAN deaktiviere und anschliessend
wieder aktiviere, ist mein Router nicht mehr erreichbar und es làßt
sich keine Verbindung mehr aufbauen.

Starte ich dagegen die SUSE (11.0/64-Bit) ohne Xen, habe ich, so lange
ich will, einen funktionierenden WLAN-Zugang.



Das ist die Dom0, richtig? Da darf man nach Aufbau der Netzwerkbrücke
nicht an der Netzwerkkonfiguration rumspielen, wie das bei WLAN fast
zwangslàufig notwendig ist:

/usr/share/doc/packages/xen/README.SuSE
| Due to the renaming of network interfaces by the network-bridge script
| (e.g. eth0 to peth0), network interfaces should not be configured or
| restarted while they are enslaved to a Xen bridge.

Funktioniert WLAN für die virtuellen Systeme? Es wàre zu überlegen, ob
man das Netz statt mit einer Brücke nicht mit NAT aufbaut.

Günther

Ähnliche fragen