Xfce/Ubuntu: keine Textkonsolen mehr

18/03/2013 - 19:27 von Ralph Stahl | Report spam
Moin!

Dieser Fehler geistert schon seit Jahren und für alle möglichen
Konstellationen durch die Foren, und nun hat er mich auch erwischt :-(.
Ich habe keine Textkonsolen mit Alt-Ctrl-F1 bis F6 mehr; X hingegen
làuft problemlos. Die Konsolen bleiben schwarz, kein Prompt sichtbar.

In dmesg taucht gelegentlich dieses auf:

NVRM: Your system is not currently configured to drive a VGA console
NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
NVRM: requires the use of a text-mode VGA console. Use of other console
NVRM: drivers including, but not limited to, vesafb, may result in
NVRM: corruption and stability problems, and is not supported.

Was da steht klingt einfach, nur, wie kann ich das erreichen? Die vielen
Tips im Laufe der Jahre sind so vielfàltig, DIE Lösung habe ich nicht
gefunden. Und wieso taucht das plötzlich auf? Ich benutze es sehr
selten, daher weiß ich nicht, seit wann es nicht mehr geht.

Könnte es an

lsmod | grep vesa
vesafb 13516 1

liegen? Den Tip in [1] liest man immer wieder.

Ich bitte um Ideen. Ich will nicht einfach rumbasteln und dauernd nichts
mehr sehen ;-).

Ralph




[1] http://www.nvnews.net/vbulletin/sho...hp?p%72859

System:

Ubuntu 12.04
Xfce 4.10
nvidia 304.84
 

Lesen sie die antworten

#1 Reinhard Tchorz
18/03/2013 - 20:24 | Warnen spam
Am 18.03.2013 19:27, schrieb Ralph Stahl:
Moin!

Dieser Fehler geistert schon seit Jahren und für alle möglichen Konstellationen durch die Foren, und nun hat er mich auch erwischt :-(. Ich habe keine Textkonsolen mit Alt-Ctrl-F1 bis F6 mehr; X hingegen làuft problemlos. Die Konsolen bleiben schwarz, kein Prompt sichtbar.

In dmesg taucht gelegentlich dieses auf:

NVRM: Your system is not currently configured to drive a VGA console
NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
NVRM: requires the use of a text-mode VGA console. Use of other console
NVRM: drivers including, but not limited to, vesafb, may result in
NVRM: corruption and stability problems, and is not supported.

Was da steht klingt einfach, nur, wie kann ich das erreichen? Die vielen Tips im Laufe der Jahre sind so vielfàltig, DIE Lösung habe ich nicht gefunden. Und wieso taucht das plötzlich auf? Ich benutze es sehr selten, daher weiß ich nicht, seit wann es nicht mehr geht.

Könnte es an

lsmod | grep vesa
vesafb 13516 1

liegen? Den Tip in [1] liest man immer wieder.

Ich bitte um Ideen. Ich will nicht einfach rumbasteln und dauernd nichts mehr sehen ;-).



Der nVidia-Treiber ist die Ursache. Bei mir tritt der gleiche Fehler mit der Version 304.84 auf.
Mit der àlteren Version 304.64 dagegen nicht.

Gruß
Reinhard

Gentoo Kernel 3.6.11 X-Server 1.13.1 KDE 4.9.5
Asus M2A-VM AMD Athlon X2 4450e Nvidia 7300LE

Ähnliche fragen