xkb-Problem (xorg 7.2)

01/09/2007 - 18:39 von Matthias Schündehütte | Report spam
Hallo,

ich verecke hier gerade an einem xkb-Problem und leiste hiermit den
Offenbarungseid: Ich weiß mir nicht mehr zu helfen!

Das ganze mit FreeBSD 6-STABLE, xorg 7.2 und KDE 3.5.7.

Ich habe unter X11 seit dem Upgrade auf xorg 7.2 keine 'Pipe' mehr
(AltGr + "<"), statdessen springt die bash an den Anfang des
Kommandozeilenstack ( mit AltGr + ">" an's Ende ).

In der Xorg.0.log steht der übliche Fehler bzgl. eines xkb-Fehlers und
dem Fallback auf Pre-XKB Verhalten:

"(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap"

Im X11 startenden Kommandozeilen-Screen làßt sich dann folgender
xkbcomp-Fehler finden:

The XKEYBOARD Keymap compiler (xkbcomp) reports:
Error: Can't find file "unknown" for geometry include
Exiting
Abandoning geometry file "default"

Ich habe gegoogelt, gegrept ... nix gefunden. Hàufige Ursache eines
solchen Fehlers scheint der fehlende Link nach /var/lib/xkb gewesen zu
sein - den gibt's aber bei mir!

Ich habe daraufhin xorg komplett de- und dann neuinstalliert - keine
Änderung. Ich habe kdebase neu installiert - keine Änderung.

Es ist Useraccount-unabhàngig.

Es tritt auf meiner FreeBSD-Maschine @work nicht auf.

Es tritt in der virtuellen Maschine (Parallels) auf meinem Mac nicht auf.

Aber auf meinem altgedienten FreeBSD-Hobel bekomme ich es nicht weg.

Hat jemand noch eine Idee?
Ciao/BSD - Matthias

Matthias Schuendehuette <msch [at] snafu.de>, Berlin (Germany)
PGP-Key at <pgp.mit.edu> and <wwwkeys.de.pgp.net> ID: 0xDDFB0A5F
 

Lesen sie die antworten

#1 Alexander Leidinger
02/09/2007 - 12:43 | Warnen spam
Quoting Matthias Schündehütte (Sat, 1 Sep 2007 18:39:57 +0200):

Hallo,

ich verecke hier gerade an einem xkb-Problem und leiste hiermit den
Offenbarungseid: Ich weiß mir nicht mehr zu helfen!

Das ganze mit FreeBSD 6-STABLE, xorg 7.2 und KDE 3.5.7.

Ich habe unter X11 seit dem Upgrade auf xorg 7.2 keine 'Pipe' mehr
(AltGr + "<"), statdessen springt die bash an den Anfang des
Kommandozeilenstack ( mit AltGr + ">" an's Ende ).



Irgendwas derart hatte ich auch mal.

In der Xorg.0.log steht der übliche Fehler bzgl. eines xkb-Fehlers und
dem Fallback auf Pre-XKB Verhalten:

"(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap"

Im X11 startenden Kommandozeilen-Screen làßt sich dann folgender
xkbcomp-Fehler finden:

The XKEYBOARD Keymap compiler (xkbcomp) reports:
Error: Can't find file "unknown" for geometry include
Exiting
Abandoning geometry file "default"

Ich habe gegoogelt, gegrept ... nix gefunden. Hàufige Ursache eines
solchen Fehlers scheint der fehlende Link nach /var/lib/xkb gewesen zu
sein - den gibt's aber bei mir!



Meinst Du damit den im /usr/X11R6/share/X11/xkb/compiled Verzeichnis?
Falls nicht, stell mal sicher, dass es das compiled Verzeichnis
überhaupt gibt.

Ich habe daraufhin xorg komplett de- und dann neuinstalliert - keine
Änderung. Ich habe kdebase neu installiert - keine Änderung.

Es tritt auf meiner FreeBSD-Maschine @work nicht auf.

Es tritt in der virtuellen Maschine (Parallels) auf meinem Mac nicht auf.

Aber auf meinem altgedienten FreeBSD-Hobel bekomme ich es nicht weg.

Hat jemand noch eine Idee?



find /usr/local/ -type d -print | grep -i x11
auf einer Maschine auf der es klappt und einer auf der es nicht klappt.

Vergleich dann mal was raus kommt. Falls das nicht hilft, das selbe in
grün (-type f).

Bye,
Alexander.

...and that is how we know the Earth to be banana-shaped.
http://www.Leidinger.net Alexander @ Leidinger.net: PGP ID = B0063FE7
http://www.FreeBSD.org netchild @ FreeBSD.org : PGP ID = 72077137

Ähnliche fragen