XL2003 Formel Mittelwert erzeugt „#Wert!“

23/07/2009 - 17:21 von Stefan Brand | Report spam
Hallo,

ich arbeite mit WinXP-SP2 und Office2003-SP3.

Ich möchte mir aus einer Reihe von Daten einen Mittelwert erzeugen lassen.
In der Spalte A habe ich alle meine Werte stehen und in der Spalte B möchte
ich die Mittelwerte angezeigt bekommen. Meine Formel lautet:

=MITTELWERT(WENN($A$2:$A$75<>0;$A$2:$A$75;"NULL"))

Das ganze funktioniert wunderbar, wenn ich in der Spalte A einen Wert stehen
habe, der größer 0 ist. Wenn ich in der Spalte A jedoch den Wert 0 stehen
habe, dann bekomme ich in der Spalte B, in dieser die Formel steht, die
Fehlermeldung: „#Wert!“ zurück.

Eine Beispieldatei habe ich abgespeichert unter:
http://home.arcor.de/stefan.brand/e...elwert.xls

Wer kann helfen?
 

Lesen sie die antworten

#1 Wolfgang Kutsche
23/07/2009 - 17:57 | Warnen spam
Hallo Stefan,

ich war zwar nicht in Deiner Datei, aber ich denke Du wolltest dies:

=WENN(SUMME(A22:A29)<>0;MITTELWERT(A22:A29);"NULL")

Die Zellen sind noch auf Deine Anforderungen anzupassen.
Ein Mittelwert aus dem Text "Null" (mit Deiner Formel ... Sonst_Wert) ist
nicht möglich, deshalb #Wert!-Fehler.

Gruß Wolfgang
WinXP Home SP3, Office 2003 SP3 & 2007 SP1
http://www.wk-bau-edv.de


"Stefan Brand" wrote:

Hallo,

ich arbeite mit WinXP-SP2 und Office2003-SP3.

Ich möchte mir aus einer Reihe von Daten einen Mittelwert erzeugen lassen.
In der Spalte A habe ich alle meine Werte stehen und in der Spalte B möchte
ich die Mittelwerte angezeigt bekommen. Meine Formel lautet:

=MITTELWERT(WENN($A$2:$A$75<>0;$A$2:$A$75;"NULL"))

Das ganze funktioniert wunderbar, wenn ich in der Spalte A einen Wert stehen
habe, der größer 0 ist. Wenn ich in der Spalte A jedoch den Wert 0 stehen
habe, dann bekomme ich in der Spalte B, in dieser die Formel steht, die
Fehlermeldung: „#Wert!“ zurück.

Eine Beispieldatei habe ich abgespeichert unter:
http://home.arcor.de/stefan.brand/e...elwert.xls

Wer kann helfen?

Ähnliche fragen