XML in ACC 07

07/11/2007 - 11:23 von Peter Meininger | Report spam
Guten Tag!

Folgende Sub habe ich in einem Modul.

Public MyToogleButtonCallbackOnAction(control As IRibbonControl)

Beim Kompilieren bekomme ich folgende Fehlermeldung. "Benutzerdefinierter
Typ nicht definiert" und beim Klicken des Buttons (s. XML) habe ich folgenden
Fehler:

"Kann das Makro- oder die Rückruffunktion MyButtonCallbackOnAction nicht
ausführen. (Parameter nicht korrekt)"

Zusàtzlich habe ich folgende XML geschrieben:

- <customUI xmlns="http://schemas.microsoft.com/office...">
- <ribbon startFromScratch="true">
- <tabs>
- <tab id="Buchung" label="Buchung">
- <group id="Einzelbuchung" label="Einzelbuchung">
<labelControl id="myLabel1" label="Beispiel:" />
<labelControl id="myLabel2" label="Gruppen" />
<button id="MyBtn1" size="large" label="Pushme"
imageMso="BevelShapeGallery" onAction="MyButtonCallbackOnAction" />
</group>
</tab>
<tab id="Abfragen" label="Abfragen" />
<tab id="Kostenrechnung" label="Kostenrechnung" />
<tab id="Bilanz" label="Bilanz" />
<tab id="Hilfe" label="Hilfe" />
</tabs>
</ribbon>
</customUI>

Wo habe ich das Problem? Bitte Hilfe. Danke.

LG Peter
 

Lesen sie die antworten

#1 André Minhorst
07/11/2007 - 11:41 | Warnen spam
Hi Peter,

Peter Meininger schrieb:
Folgende Sub habe ich in einem Modul.

Public MyToogleButtonCallbackOnAction(control As IRibbonControl)

Beim Kompilieren bekomme ich folgende Fehlermeldung. "Benutzerdefinierter
Typ nicht definiert" und beim Klicken des Buttons (s. XML) habe ich folgenden
Fehler:

"Kann das Makro- oder die Rückruffunktion MyButtonCallbackOnAction nicht
ausführen. (Parameter nicht korrekt)"

Zusàtzlich habe ich folgende XML geschrieben:

- <customUI xmlns="http://schemas.microsoft.com/office...">
- <ribbon startFromScratch="true">
- <tabs>
- <tab id="Buchung" label="Buchung">
- <group id="Einzelbuchung" label="Einzelbuchung">
<labelControl id="myLabel1" label="Beispiel:" />
<labelControl id="myLabel2" label="Gruppen" />
<button id="MyBtn1" size="large" label="Pushme"
imageMso="BevelShapeGallery" onAction="MyButtonCallbackOnAction" />
</group>
</tab>
<tab id="Abfragen" label="Abfragen" />
<tab id="Kostenrechnung" label="Kostenrechnung" />
<tab id="Bilanz" label="Bilanz" />
<tab id="Hilfe" label="Hilfe" />
</tabs>
</ribbon>
</customUI>

Wo habe ich das Problem? Bitte Hilfe. Danke.



Verweis auf Microsoft Office 12.0 Object Library gesetzt?

Ciao
André


http://www.access-entwicklerbuch.de
http://www.access-im-unternehmen.de

Ähnliche fragen