Xorg: Bild zu weit rechts

29/12/2008 - 14:41 von Egon Schmid | Report spam
Hallo!

Ich habe nun einen neuen Monitor, einen ASUS VW222U, angeschlossen.
Die Xorg.conf habe ich geàndert, dass die 1680x1050 Auflösung verwendet
wird.

Leider ist das Bild um geschàtzte 12 cm zu weit nach rechts verschoben,
ich kann zwar im Monitor-Menü das Bild noch etwas nach links
verschieben, aber dann hàngt das Bild immer noch um ca. 8cm zu weit nach
rechts.

Beim Herumgooglen stellte ich zwar fest, dass viele dasselbe Problem
haben, aber eine vernünftige Lösung war bisher nicht zu finden.

Vielleicht weiss hier jemand die Lösung?

Inhalt der Xorg.conf:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "dri"
Load "glx"
Load "dbe"
Load "record"
Load "xtrap"
Load "GLcore"
Load "extmod"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
### Comment all HorizSync and VertRefresh values to use DDC:
HorizSync 31.5 - 92.0
VertRefresh 50.0 - 100.0
Modeline "1680x1050@75" 210.42 1680 1712 2504 2536 1050 1070 1083 1103
EndSection

Section "Device"

### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Card0"
Driver "i810"
VendorName "Intel Corporation"
BoardName "82945G/GZ Integrated Graphics Controller"
BusID "PCI:0:2:0"
# Option IgnoreEDID true
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Modes "1680x1050"
Depth 24
EndSubSection
EndSection

Section "DRI"
Group 0
EndSection


Viele Grüße

Egon Schmid
 

Lesen sie die antworten

#1 Henning Paul
29/12/2008 - 14:48 | Warnen spam
Egon Schmid wrote:

Ich habe nun einen neuen Monitor, einen ASUS VW222U, angeschlossen.
Die Xorg.conf habe ich geàndert, dass die 1680x1050 Auflösung
verwendet wird.



Hast Du die Modeline selbst erzeugt? Mal xtiming probiert?

Gruß
Henning

Ähnliche fragen