Forums Neueste Beiträge
 

[XP Home] UrlDownloadToFile

28/09/2012 - 00:04 von christian_dcomwm-ENTF | Report spam
Hi,

seit Stunden sitze ich an einem mysteriösen Problem, vielleicht hat von
euch einer eine Idee:
Beim Versuch, in einem AutoHotKey-Script mit UrlDownloadToFile Firefox-
Erweiterungen herunterzuladen, wird jedes Mal nur eine Nullbyte-Datei
angelegt.
Die gleiche XPI-Datei wird auf anderen Rechnern ohne weiteres mit
_gleichem Scriptbefehl_ heruntergeladen. Auf dem Problemrechner
funktioniert der Download aus FF oder IE. Alle anderen Dateien, auch
ausführbare von anderen Seiten mit/ohne SSL werden klaglos vom Script
geladen.
Nur die Firefox-Plugins auf diesem Rechner, per Scriptbefehl - keine
Chance. Angemeldet als Admin, alle Patches geladen, keine anderen
Anwendungen aktiv, auch in anderen Verzeichnissen probiert,
Ereignisprotokoll unauffàllig. Mit autoruns.exe habe ich schon alles, was
nicht zwingend nötig ist, deaktiviert, frisches Userprofil angelegt,
andere Zieldateinamen probiert - nix. Die URL enthàlt auch keinen Escape-
Character (`%,;).

Ich bin mit meinem Latein am Ende. Wenn da Malware liefe, würde sie ja
vermutlich auch den Download per FF oder IE unterbinden oder sich nicht
gerade auf xpi beschrànken.

Was an dem Rechner "anders" ist als an den anderen Kandidaten: es ist
eine Home-Version und ich hatte die ~NoExecute.inf installiert. Nachdem
es nur Fehlermeldungen hagelte, fiel mir erst auf, daß Windows auf einer
FAT32-Partition liegt und ich habe die .inf wieder deinstalliert.

cu,
Christian


Hier "das Script", welches nur eine 0-Byte-Datei hinterlàßt:
UrlDownloadToFile,https://addons.mozilla.org/firefox/...script.zip

Wenn es jemand parat hat, kann ich es testweise auch mal mit einem
Powershell-Script probieren, damit kenne ich mich überhaupt nicht aus.
 

Lesen sie die antworten

#1 Ruediger Lahl
28/09/2012 - 11:17 | Warnen spam
Christian @Soemtron wrote:

Nur die Firefox-Plugins auf diesem Rechner, per Scriptbefehl - keine
Chance. Angemeldet als Admin, alle Patches geladen, keine anderen
Anwendungen aktiv, auch in anderen Verzeichnissen probiert,
Ereignisprotokoll unauffàllig. Mit autoruns.exe habe ich schon alles, was
nicht zwingend nötig ist, deaktiviert, frisches Userprofil angelegt,
andere Zieldateinamen probiert - nix. Die URL enthàlt auch keinen Escape-
Character (`%,;).

Ich bin mit meinem Latein am Ende.



Schuss ins blaue, aber IIRC werden XPIs auch mal via JavaScript
ausgeliefert. Ist das bei dem Problemrechner aktiviert?

Hier "das Script", welches nur eine 0-Byte-Datei hinterlàßt:
UrlDownloadToFile,https://addons.mozilla.org/firefox/...script.zip



Wo kommt das .zip her? XPIs sind zwar Zips, aber sie heissen nicht so.

BTW: Versuche es auch mal in den mozilla-Gruppen.
bis denne

Ähnliche fragen