Yosemite in VirtualBox

23/07/2015 - 10:12 von Gerhard Landeck | Report spam
Hi,

ich wollte mir mal unverbindlich Yosemite anschauen.
Dabei ging ich zunàchst nach dieser Anleitung vor:

http://www.fredmastro.com/?p@

Hat irgendwie nicht geklappt, deshalb ging ich dann nach der hier vor:

http://sqar.blogspot.de/2014/10/ins...albox.html

Hier sind die Einzelbefehle gleich in einem Skript zusammengefasst.

Das Iso-Image wurde jedenfalls erzeugt, aber n irgendeiner Stelle
scheiterte die Installation, ich glaube es wurde zu wenig
Festplattenplatz angemckert.

Jedenfalls habe ich das Image wieder gelöscht und wollte von vorne
anfangen. Wenn ich das Skript nun ausführe, kriege ich sofort die
Fehlermeldung

hdiutil: attach failed - Ressource ist belegt

Wie kriege ich raus, welche Resource das ist und wie kriege ich die
wieder frei?

Hoffe, die Infos sind ausreichend...

Gruß, Gerhard
 

Lesen sie die antworten

#1 Gerhard Landeck
28/07/2015 - 11:06 | Warnen spam

Das Iso-Image wurde jedenfalls erzeugt, aber n irgendeiner Stelle
scheiterte die Installation, ich glaube es wurde zu wenig
Festplattenplatz angemckert.

Jedenfalls habe ich das Image wieder gelöscht und wollte von vorne
anfangen. Wenn ich das Skript nun ausführe, kriege ich sofort die
Fehlermeldung

hdiutil: attach failed - Ressource ist belegt

Wie kriege ich raus, welche Resource das ist und wie kriege ich die
wieder frei?




Der Befehl, der die Fehlermeldung auslöst ist folgender:

hdiutil attach /Applications/Install\ OS\ X\
Yosemite.app/Contents/SharedSupport/InstallESD.dmg -noverify -nobrowse
-mountpoint /Volumes/install_app


Soweit ich hdiutil attach verstehe, ist die Quelle

/Applications/Install\ OS\ X\
Yosemite.app/Contents/SharedSupport/InstallESD.dmg

und /Volumes/install_app das Ziel. Fragt sich, welches davon mit
Resource gemeint ist.

Weder mit ps -ef noch mit der Aktivitàtsanzeige kann ich irgendwas
finden, was auf eins der beiden hindeutet. In Letzterer findet man
aber die Prozesse Installer (dem User gehörend) und installd (gehört
root). Ich habe schon gemetagert, aber nicht Vernünftiges gefunden:
Laufend diese beiden Prozesse immer? Kann man die beenden? Haben die
überhaupt was mit dem Problem zu tun?
Installer habe ich versucht zu beenden, der wird aber sofort wieder
nachgestartet.

Bin mal gespannt, ob jetzt jemand reagiert.

Gruß, Gerhard

Ähnliche fragen