Forums Neueste Beiträge
 

Zählen wenn in einer Zeile zwei Texte als Zelleninhalt vorkommen?

05/06/2009 - 15:35 von franz47 | Report spam
Habe als seltener 08/15 Excel Benutzer gesucht und nicht gefunden.
Es existiert ein Excel-Datei, die eine tàgliche Platzierung von Personen an
mehreren Arbeitsplàtzen an jedem Tag auflistet.
1. Spalte Wochentag
2. Spalte Datum
3. Spalte Arbeitsposition 1 - im Feld der Name der Person, die die Position
ausfüllt.
4. Spalte Arbeitsposition 2
.
usw.

Ich will eine Tabelle, wo die senkrechte Achse alle Personennamen und die
waagrechte alle Wochentage sind, in den Feldern dann wieviele dieser Tage die
Person X jeweils gearbeitet hat, d.h. z.B. wieviele Montage Person X gearbeitet
hat etc.

Die Bedingung ist also: zàhle, wenn in einer Zeile der Datei sowohl Montag als
auch der Name der Person X vorkommen.
Das dann für alle Wochentage und alle Personen in die Tabelle einfügen.

Wie mache ich das?
Dankbar für einen Tip
Franz47
 

Lesen sie die antworten

#1 Claus Busch
05/06/2009 - 15:59 | Warnen spam
Hallo Franz,

Am Fri, 5 Jun 2009 15:35:55 +0200 schrieb franz47:

Ich will eine Tabelle, wo die senkrechte Achse alle Personennamen und die
waagrechte alle Wochentage sind, in den Feldern dann wieviele dieser Tage die
Person X jeweils gearbeitet hat, d.h. z.B. wieviele Montage Person X gearbeitet
hat etc.

Die Bedingung ist also: zàhle, wenn in einer Zeile der Datei sowohl Montag als
auch der Name der Person X vorkommen.
Das dann für alle Wochentage und alle Personen in die Tabelle einfügen.



Gehe auf ein neues Tabellenblatt und von dort aus auf Daten => Filter =>
Spezialfilter. Gebe dort als Listenbereich deine Spalte C aus der
Übersichtstabellen an. Aktiviere "An andere Stelle filtern" und gebe bei
"Kopieren nach" A1 der neuen Tabelle ein. Aktiviere dann noch "Keine
Duplikate" und gehe auf "ok". Damit hast du eine Namensliste aller
Miutarbeiter ohne Duplikate. Schreibe nun ab B1 nach rechts deine
Wochentage rein. In B2 gebe ein:
=SUMMENPRODUKT((Tabelle1!$C$2:$C$100=$A2)*(Tabelle1!$A$2:$A$100=B$1))
und ziehe die Formel nach unten so weit du Namen hast und nach rechts so
weit du Wochentage hast.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP3 / Vista Ultimate SP1
Office 2003 SP3 / 2007 Ultimate SP2

Ähnliche fragen