Zählenwenn mit Datum

07/11/2010 - 17:35 von Maria Tuft | Report spam
Hallo,
ich habe eine Liste mit Spalte A = Datum, Spalte B = Typ.
Es gibt 5 Typen. Diese werden derzeit in einem anderen Tabellenblatt gezàhlt
mit:
=ZÄHLENWENN(Eingabe!CB:B74;"Test")
Ergibt dann:
Typ1 = 12
Typ2 = 34
...

Wie kann ich zusàtzlich noch das Datum in die Abfrage einbauen, so daß nur
gezàhlt wird wenn Datum im Jahr 2008 war.
Ich möchte am Ende dann für jedes Jahr eine Anzahl zàhlen (statt alle
zusammen).
Typ1 2008 = 1
Typ1 2009 = 8
Typ1 2010 = 3
...

Wie muss hier die Formel dann heißen?

Vielen Dank
 

Lesen sie die antworten

#1 Claus Busch
07/11/2010 - 17:46 | Warnen spam
Hallo Maria,

Am Sun, 7 Nov 2010 17:35:03 +0100 schrieb Maria Tuft:

Wie kann ich zusàtzlich noch das Datum in die Abfrage einbauen, so daß nur
gezàhlt wird wenn Datum im Jahr 2008 war.
Ich möchte am Ende dann für jedes Jahr eine Anzahl zàhlen (statt alle
zusammen).
Typ1 2008 = 1
Typ1 2009 = 8
Typ1 2010 = 3



z.B. so für 2008 und Typ1:
=SUMMENPRODUKT(--(JAHR(A1:A100) 08);--(B1:B100="Typ1");--(C1:C100="Test"))

Oder mache es mit einer Pivot-Tabelle. Deine Tabelle muss Überschriften
haben. Dann ziehe für die Pivot-Tabelle das Datum in den Zeilenbereich,
den Typ einmal in den Spaltenbereich und einmal in den Wertebereich.
Mache dann einen Rechtsklick auf eine Zelle mit Datum und wàhle dann
"Gruppieren" und stelle dort "Jahre" ein.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen