ZählenWenn mit mehr als einem Kriterium

07/10/2008 - 14:47 von Thomas Wolf | Report spam
Hallo zusammen

Ich versuche eine Funktion zu bauen, wo ich 2 verschiedene Kriterien für
'ZàhlenWenn' eingeben kann. Anscheinend gibt es das in O07, aber wie mache
ich das vorher?

Mein bisheriges Konstrukt fàllt schon bei Zeile 20 auf die Nase. Was mache
ich falsch? Oder hat dies schon jemand gemacht und würde mir weiterhelfen?

Function fctCountIf(rng1 As Range, value1 As Long, rng2 As Range, value2 As
Long)
Dim c As Range
Dim lngCounter As Long
10 lngCounter = 0
20 For Each c In Range(rng1)
30 If c.Value = value1 Then
40 lngCounter = lngCounter + 1
50 Debug.Print c.Value
60 End If
70 Next c
80 fctCountIf = lngCounter
End Function


Danke und Gruss
Thomas
 

Lesen sie die antworten

#1 Claus Busch
07/10/2008 - 15:00 | Warnen spam
Hallo Thomas,

Am Tue, 7 Oct 2008 14:47:38 +0200 schrieb Thomas Wolf:

Ich versuche eine Funktion zu bauen, wo ich 2 verschiedene Kriterien für
'ZàhlenWenn' eingeben kann. Anscheinend gibt es das in O07, aber wie mache
ich das vorher?



du brauchst dir nicht eigenes zu basteln. Es geht auch mit
Excel-Bordmitteln.
Im Bereich A1:A25 sollen die Zehlen gezàhlt werden die > und <100
sind. Dann geht es so:
=SUMMENPRODUKT((A1:A25> )*(A1:A25<100))
oder so:
=ZÄHLENWENN(A1:A25;"<100")-ZÄHLENWENN(A1:A25;"<20")


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP3 / Vista Ultimate
Office 2003 SP3 / 2007 Ultimate SP1

Ähnliche fragen