zählenwenn.

15/12/2011 - 15:31 von michlchen | Report spam
hallo ng.

ich nutze derzeit die funktion zàhlenwenn um herauszubekommen, wie oft
in einem bestimmten bereich der begriff "*url*" vorkommt. jetzt möchte
ich aber gerne ausschliessen, dass "1/2 url" auch mitgezàhlt wird,
weil ich das gerne selber dazurechnen würde (ihr ahnt sicherlich, was
für ein tool das ist *g*)


jedenfalls wie würde man folgendes als formel umsetzen. (keine makros,
da ich die datei als xlsx abspeichern will.)
ZÄHLENWENN(D2:BB32; "*Url*" and not "*1/2*")

danach würde ich nat. ZÄHLENWENN(D2:BB32; "*1/2*")/2 dazuaddieren
wollen.

jemand ne idee? hab da im netz was von summenprodukt gelesen, aber da
gings meist darum abzufragen in spalte a muss x und in spalte b muss y
sein...
 

Lesen sie die antworten

#1 Frank Willberger
16/12/2011 - 07:40 | Warnen spam
Moin, Moin!

ich nutze derzeit die funktion zàhlenwenn um herauszubekommen, wie oft
in einem bestimmten bereich der begriff "*url*" vorkommt. jetzt möchte
ich aber gerne ausschliessen, dass "1/2 url" auch mitgezàhlt wird,
weil ich das gerne selber dazurechnen würde (ihr ahnt sicherlich, was
für ein tool das ist *g*)


jedenfalls wie würde man folgendes als formel umsetzen. (keine makros,
da ich die datei als xlsx abspeichern will.)
ZÄHLENWENN(D2:BB32; "*Url*" and not "*1/2*")

danach würde ich nat. ZÄHLENWENN(D2:BB32; "*1/2*")/2 dazuaddieren
wollen.

jemand ne idee? hab da im netz was von summenprodukt gelesen, aber da
gings meist darum abzufragen in spalte a muss x und in spalte b muss y
sein...



Du hast doch in Deinem Ansatz mit dem logischen "and not" schon fast die
Lösung beschreiben:

=ZÄHLENWENN(D2:BB32; "*Url*")-ZÄHLENWENN(D2:BB32; "1/2 Url*")


Oder den zweiten Term
=ZÄHLENWENN(D2:BB32; "1/2 Url*")*0,5
in eine eigene Zelle (a2)

Und dann
=ZÄHLENWENN(D2:BB32; "*Url*")-2*A2

Ciao


Frank
Liebe deine Feinde, aber sei schneller als sie!

Ähnliche fragen