zählvariable in sverweis mitlaufen lassen

29/07/2009 - 13:08 von klaus.könig | Report spam
hallo

ich will, dass zellen ab e15 solange die funktion sverweis erhalten,
bis die entsprechende erste leere zelle in spalte b kommt. hierzu habe
ich den unten genannten code vorbereitet. was dort noch nicht
funktioniert ist laufende übergabe der zelladresse als b15, b16 usw.

hat da jemand eine idee?

freue mich auf eine antwort.

Sub EinhErmitteln()
Dim ersteZeile As Long, letzteZeile As Long, i As Long
Dim varZelle As Variant
ersteZeile = Range("B14").Row 'Zàhler für die erste Zeile
letzteZeile = Range("B14").End(xlDown).Offset(0, 0).Row 'Zàhler für
die letzte Zeile
'MsgBox ersteZeile
'MsgBox letzteZeile
For i = ersteZeile + 1 To letzteZeile

' varZelle = "B" & i
' MsgBox varZelle
Range("E" & i).FormulaLocal = "=SVERWEIS(B&i);xTab_Massnahmen!$A
$3:$L$22;6;FALSCH)"
Next

End Sub
 

Lesen sie die antworten

#1 Alexander Wolff
29/07/2009 - 13:15 | Warnen spam
Die Tastatur von klaus.könig wurde wie folgt gedrückt:
ich will, dass zellen ab e15 solange die funktion sverweis erhalten,
bis die entsprechende erste leere zelle in spalte b kommt. hierzu habe
ich den unten genannten code vorbereitet. was dort noch nicht
funktioniert ist laufende übergabe der zelladresse als b15, b16 usw.

For i = ersteZeile + 1 To letzteZeile
Range("E" & i).FormulaLocal = "=SVERWEIS(B&i);xTab_Massnahmen!$A
$3:$L$22;6;FALSCH)"
Next



Range("E" & i).FormulaLocal "=SVERWEIS(B" & i & ");xTab_Massnahmen!$A$3:$L$22;6;FALSCH)"

ist das, was Du vermutlich brauchst.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen