Forums Neueste Beiträge
 

zeichen automatisch entfernen und einfügen

17/06/2013 - 07:55 von f.loetzsch | Report spam
Ich habe folgendes Problem:

Ich bekomme aus einem System eine List mit teilweise negative Zahlen in diesem Format ausgespuckt: 123.456,78cr
Um weiter mit diesen Daten arbeiten zu können, muss diese Zahlen in dieses Format geàndert werden: -123.456,78.

Ich habe mit der Formel: =WECHSELN(A1;"cr";"") das cr entfernen können.

Mit einer zweiten Formel: = LINKS(A2;0) & "-" & TEIL(A2;1;999) habe ich das - einfügen können.

Problem: wenn ich diese beiden Formeln nach einander auf die komplette Tabelle anwende, werde auch meine eigentlich positiven Zahlen, die nicht geàndert werden sollen, mit einem - versehen.

Daher meine Frage: kann man beide Befehle kombinieren? Ich stell mir das mit einer wenn-dann-formel vor. Wenn das Cr entfernt wird, dann - einfügen.

Geht das? Oder gibt es noch einen einfacheren (besseren) Weg?

Ich würde mich freuen, wenn mir einer einen guten Rat geben könnte.

Vielen Dank und freundliche Grüße
Franziska
 

Lesen sie die antworten

#1 Claus Busch
17/06/2013 - 08:12 | Warnen spam
Hallo Franziska,

Am Sun, 16 Jun 2013 22:55:06 -0700 (PDT) schrieb
:

Ich habe mit der Formel: =WECHSELN(A1;"cr";"") das cr entfernen können.

Mit einer zweiten Formel: = LINKS(A2;0) & "-" & TEIL(A2;1;999) habe ich das - einfügen können.



deine letzte Formel zum Einfügen des Minuszeichens ist eine
Textfunktion. Damit bleibt dein Wert immer noch Text.
Probiere es mal so:
=WENN(ISTZAHL(FINDEN("cr";A1));-1*WECHSELN(A1;"cr";);A1)


Mit freundlichen Grüßen
Claus Busch
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen