Zeichensatz des Headers

26/04/2008 - 01:08 von Arnulf Sopp | Report spam
Moin!

Es war einmal ein Umlaut im Betreff einer Nachricht, auf die ich mit
dem gewohnten Klick antwortete, ohne mir Gedanken darüber zu machen.
Ein Reply bemàngelte nun, das Subject sei unleserlich geworden. Dies
war das erste Mal, dass ich darauf aufmerksam gemacht wurde. Somit
kann es kaum oft vorgekommen sein, meine Einstellungen sind also
vermutlich ganz ordentlich - aber offensichtlich eben nicht perfekt.

Nun suchte ich mir einen Wolf nach einer Möglichkeit, den Zeichensatz
des Headers korrekt zu kodieren, fand aber nichts.

Was muss getan werden, damit der Betreff bei möglichst jedem Reader
richtig wiedergegeben wird, wenn er 8-Bit-Zeichen enthàlt? Das
betrifft nicht nur das Subject, sondern wenn jemand Jürgün Schrödör
heißt, hat er dasselbe Problem.

Tschüs!

Arnulf
 

Lesen sie die antworten

#1 Heiko Rost
26/04/2008 - 03:59 | Warnen spam
Am Sat, 26 Apr 2008 01:08:55 +0200 schrieb Arnulf Sopp:

Es war einmal ein Umlaut im Betreff einer Nachricht, auf die ich mit
dem gewohnten Klick antwortete, ohne mir Gedanken darüber zu machen.
Ein Reply bemàngelte nun, das Subject sei unleserlich geworden. Dies
war das erste Mal, dass ich darauf aufmerksam gemacht wurde. Somit
kann es kaum oft vorgekommen sein, meine Einstellungen sind also
vermutlich ganz ordentlich - aber offensichtlich eben nicht perfekt.



Dialog veràndert beim Antworten das Subject nicht, es ist in Deiner Antwort
also genauso richtig oder falsch wie das Deines Vorposters. Ob das so
richtig ist oder es besser wàre, den Betreff lieber zu korrigieren, wurde
hier in der Gruppe schon mehr als einmal diskutiert.

In dem Thread über das Fernsehen für die geistig weniger Gesegneten ist es
ein Nutzer des Forte Free Agent 1.93/32.576, der die Umlaute schrottet,
weil dieses Programm den Header nicht kodieren kann. Sobald Du auf so ein
Posting antwortest, hat Deine Antwort auch defekte Umlaute.

Nun suchte ich mir einen Wolf nach einer Möglichkeit, den Zeichensatz
des Headers korrekt zu kodieren, fand aber nichts.



Das geht nicht einzustellen.

Was muss getan werden, damit der Betreff bei möglichst jedem Reader
richtig wiedergegeben wird, wenn er 8-Bit-Zeichen enthàlt? Das betrifft
nicht nur das Subject, sondern wenn jemand Jürgün Schrödör heißt, hat er
dasselbe Problem.



Um es etwas extrem zu formulieren: Sicher sein kannst Du Dir nie.
Spàtestens, wenn auf dem System des Empfàngers keine Schrift mit den
entsprechenden Sonderzeichen (es gibt ja nicht nur die auf lateinisch
basierenden) installiert ist, kann er es nicht lesen. Ganz abgesehen von
Programmen, die mit Sonderzeichen immer noch nicht richtig umgehen können.

Wenn Du den Thread selber eröffnest, macht Dialog die Headerkodierung von
sich aus korrekt. Bei Antworten mußt Du mit dem Problem leben oder
versuchen, daß in einem OnBeforeSending-Skript zu lösen. Es gibt in der
Gruppe einige Threads dazu, das mit KorrNews zu machen. Ob diese Lösung
stabil làuft kann ich mangels Erfahrung damit nicht sagen.

Gruß Heiko

PS: Unangekündigte Crosspostings sind böse, noch dazu in verschiedene
Top-Level-Hierarchien.

Ähnliche fragen