Zeilen abhängig von anderer Tabelle löschen

25/11/2007 - 15:25 von Fabian Knauf | Report spam
Hallo,

habe zwei Tabellen:
- in einer alle Kundendaten
- in der zweiten nur eine Spalte mit Kundennummern

Ich möchte nun, dass in der 1. Tabelle alle die Zeilen gelöscht werden,
wo die Kundennummer in der zweiten Tabelle nicht vorkommt.

Wie kriege ich das mit Excel-Mitteln hin?

Danke
Fabian
 

Lesen sie die antworten

#1 Claus Busch
25/11/2007 - 16:22 | Warnen spam
Hallo Fabian,

Am Sun, 25 Nov 2007 15:25:58 +0100 schrieb Fabian Knauf:

habe zwei Tabellen:
- in einer alle Kundendaten
- in der zweiten nur eine Spalte mit Kundennummern

Ich möchte nun, dass in der 1. Tabelle alle die Zeilen gelöscht werden,
wo die Kundennummer in der zweiten Tabelle nicht vorkommt.

Wie kriege ich das mit Excel-Mitteln hin?



angenommen, in beiden Tabellen stehen die Kundennummern in Spalte A. Dann
schreibe in eine neue Spalte in Zeile 2 (da du ja bestimmt Überschriften
hast):
=ZÄHLENWENN(Tabelle2!A:A;A2)
Nun kannst du die Tabelle nach 0 filtern, das sind dann die Eintràge, die
keine Entsprechung in Tabelle2 haben. Diese Zeilen kannst du nun löschen.
Oder probiere es mit VBA. Kopiere den folgenden Code in ein Standardmodul
und rufe das Makro Loeschen auf:
Sub Loeschen()

Dim i As Long

With Sheets("Tabelle1")
For i = .UsedRange.Rows.Count To 2 Step -1
If WorksheetFunction.CountIf(Sheets("Tabelle2") _
.Range("A:A"), Cells(i, 1)) = 0 Then
Rows(i).Delete
End If
Next
End With

End Sub


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen