Zeilen automatisch ein- und ausblenden

27/10/2008 - 18:54 von Jörg Klein | Report spam
Hallo,

ich habe ein Excelsheet, in dem ich Zeilen ein und ausblenden möchte. Die
Informationen sollen aus drei Zellen kommen. Zelle C10 ist der Startwert,
Zelle D10 ist der Endwert und Zelle E10 ist die Zàhleinheit. Beispiel:
C10 hat den Wert 80,00
D10 hat den Wert 119.80
E 10 kann die Werte von 0,2 - 0,5 annehmen

Die Tabelle selbst besitzt folgende Spalten:
B28 C28 D28 E28 F28 G28
H28
Nr. Stückzahl Alpha Wert aus C10 Formel 1 Formel 2
Formel 3

ab Zeile 28 ist der Wert 80,00 + 0,00 = 80,00
80,00 + 0,20 = 80,20
80,20 + 0,20 = 80,40 usw.

Für die Werte von 80,00 - 119,80 habe ich die Zeilen von 28 bis 227 belegt.
Der einzige Wert, der sich manuel veràndern kann ist die Spalte C28 -C227.
Veràndere ich jetzt den Wert aus E10 auf 0,5, dann muß ab Zeile 28 der Wert
folgender massen aussehen:
80,00 + 0,00 = 80,00
80,00 + 0,50 = 80,50
80,50 + 050 = 81,00 usw.

Jetzt sollten sich die Zeilen 28 - 227 entsprechend àndern. Sollte jedoch
ein Wert in Spalte C28 - C227 stehen, so darf dieser nicht überschrieben
werden, sondern muß erhalten bleiben. Wenn ich dann wieder aud 0,20 stelle,
müssen alle Zeilen von 28 - 227 wieder dasein.

Ich hoffe ich habe es nicht so kompliziert erklàrt. Auch Google hat nicht
weiter geholfen.

Vielen Dank für die Hilfe

Jörg
 

Lesen sie die antworten

#1 Claus Busch
27/10/2008 - 20:03 | Warnen spam
Hallo Jörg,

Am Mon, 27 Oct 2008 18:54:18 +0100 schrieb Jörg Klein:


Für die Werte von 80,00 - 119,80 habe ich die Zeilen von 28 bis 227 belegt.
Der einzige Wert, der sich manuel veràndern kann ist die Spalte C28 -C227.
Veràndere ich jetzt den Wert aus E10 auf 0,5, dann muß ab Zeile 28 der Wert
folgender massen aussehen:
80,00 + 0,00 = 80,00
80,00 + 0,50 = 80,50
80,50 + 050 = 81,00 usw.

Jetzt sollten sich die Zeilen 28 - 227 entsprechend àndern. Sollte jedoch
ein Wert in Spalte C28 - C227 stehen, so darf dieser nicht überschrieben
werden, sondern muß erhalten bleiben. Wenn ich dann wieder aud 0,20 stelle,
müssen alle Zeilen von 28 - 227 wieder dasein.



und ich hoffe, dass ich dich richtig verstanden habe.
C27 darf nicht leer sein und dann in C28:
=WENN(ODER(C27="";$C$10+(ZEILE()-28)*$E$10>$D$10);"";$C$10+(ZEILE()-28)*$E$10)


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP3 / Vista Ultimate
Office 2003 SP3 / 2007 Ultimate SP1

Ähnliche fragen