Zeitdauer am Stichtag

11/04/2008 - 15:26 von Andreas Tchorsch | Report spam
Hallo liebe Leute,

mal wieder eine Auswertungsfrage:

Folgende Ausgangsliste (Ergebnis meiner Anfrage vom 19.03.08):
Name1 01.01.2007 01.03.2007
Name2 01.03.2007 01.06.2007
Name3 01.02.2007 01.05.2007

Zu einem Stichtag soll die durchschnittliche Dauer in Tagen/Monaten bis zu
diesem Stichtag als Ergebnis erscheinen, also (hier in Monaten):
01.01.2007 0
01.02.2007 1 (=1 Person: 1 Monat)
01.03.2007 1,5 ( =2 Personen: 2 Monate und 1 Monat)
01.04.2007 1,5 (...)
01.05.2007 2,5 (...)
01.06.2007 3,5 ( =2 Personen: 4 Monate und 3 Monate)
01.07.2007 0

Mir fehlt im Moment der Geistesblitz, vielen Dank für eine Unterstützung und
liebe Grüße.

Andreas Tchorsch
 

Lesen sie die antworten

#1 Robert Gelbmann
12/04/2008 - 02:29 | Warnen spam
Hallo Andreas!

"Andreas Tchorsch"
schrieb ...
Folgende Ausgangsliste (Ergebnis meiner Anfrage vom 19.03.08):
Name1 01.01.2007 01.03.2007
Name2 01.03.2007 01.06.2007
Name3 01.02.2007 01.05.2007

Zu einem Stichtag soll die durchschnittliche Dauer in
Tagen/Monaten bis zu
diesem Stichtag als Ergebnis erscheinen, also (hier in Monaten):
01.01.2007 0
01.02.2007 1 (=1 Person: 1 Monat)
01.03.2007 1,5 ( =2 Personen: 2 Monate und 1 Monat)
01.04.2007 1,5 (...)
01.05.2007 2,5 (...)
01.06.2007 3,5 ( =2 Personen: 4 Monate und 3 Monate)
01.07.2007 0



*grübel*
Möglicherweise ist die Lösung - angesichts der spàten/frühen
Stunde - auch viel zu umstàndlich, aber immerhin:

Deine erste Tabelle steht in diesem Beispiel in A3:C5 (womit die
Spalte B das erste Datum und die Spalte C das zweite Datum
beinhaltet).
Die Kolonne von Stichtagen habe ich in B10:B16.

Dann würde folgende Formel funktionieren:

{=MITTELWERT(WENN(($B$3:$B$5<B10)*($C$3:$C$5>±0);B10-$B$3:$B$5))}

Zu beachten ist:

(1) Es handelt sich um eine Matrixformel:
- Die geschwungenen Klammern dürfen *nicht* eingegeben werden.
- Die Eingabe erfolgt *nicht* mit der Eingabetaste, sondern mit Strg
+ Umschalt + Eingabetaste (in *einer* einzelnen Zelle).

(2) Diese Formel führt im angeführten Beispiel (logischerweise) beim
ersten und beim letzten Stichtag zu einer #DIV/0!-Fehlermeldung.

(3) Die Ausgabe erfolgt in Tagen (nicht in Monaten).


ad (2):
Wenn du die los werden möchtest, so würde dies z.B. so
funktionieren:
{=WENN(SUMME(($B$3:$B$5<B10)*($C$3:$C$5>±0))>0;MITTELWERT(WENN(($B$3:$B$5<B10)*($C$3:$C$5>±0);B10-$B$3:$B$5));0)}

oder in Excel 2007 auch mit der neuen Tabellenfunktion WENNFEHLER:
{=WENNFEHLER(MITTELWERT(WENN(($B$3:$B$5<B10)*($C$3:$C$5>±0);B10-$B$3:$B$5));0)}


ad (3) Nachdem du ohnehin nur jeweils mit dem Monatsbeginn rechnest,
kannst du die Tage leicht in Monate umrechnen (C10 wàre die Zelle
mit oben stehender Formel):

=RUNDEN(C10/15;0)/2


Vielleicht findet ja jemand eine kürzere/elegantere Lösung?

In der Hoffnung geholfen zu haben, verbleibe ich mit einem leisen


Servus aus Wien,
-Robert Gelbmann-

I solemnly swear that I'm up to no good.

Ähnliche fragen