Zeiten in Excel/VBA

03/09/2007 - 21:29 von Jochen Walerka | Report spam
Hallo,

habe mir eine kleine Aufgabe gestellt und komme nicht weiter, weil mir
das Zeitkonzept von Excel und das Handling per VBA nicht klar ist.
Es geht (wie oft) um Arbeitszeiten, dabei zàhlt Nachtschicht z.B. von
20:00 Uhr bis 6:00 Uhr.
Jetzt können sich Arbeitszeiten genau damit decken, die Nachtschicht
voll überlappen (19:00 - 7:00) oder nur teilweise überlappen.
Da stört schonmal bei der Umrechnung in Arbeitsstunden, dass 6:00 <
20:00 ist, also teile ich die Nachtschicht in 20:00 - 24:00 und 0:00 -
6:00. Also 4 + 6 = 10 Stunden.
Und hier gehts schon los: es gibt keine 24:00-Zeit in Excel, da gehts
nur bis 23:59:59.

Frage: ist mein Konzept schon vom Ansatz her falsch und wird das
gaaanz anders gemacht?
Zusatzfrage: Wenn ich eine Date-Variable tmpzeit = "23:00" habe, wie
addiere ich da Stunden oder Minuten drauf?

Danke für Wegweisungen
Jo
 

Lesen sie die antworten

#1 Peter Schürer
04/09/2007 - 00:15 | Warnen spam
"Jochen Walerka" schrieb im Newsbeitrag
news:
Hallo,

habe mir eine kleine Aufgabe gestellt und komme nicht weiter, weil mir
das Zeitkonzept von Excel und das Handling per VBA nicht klar ist.
Es geht (wie oft) um Arbeitszeiten, dabei zàhlt Nachtschicht z.B. von
20:00 Uhr bis 6:00 Uhr.
Jetzt können sich Arbeitszeiten genau damit decken, die Nachtschicht
voll überlappen (19:00 - 7:00) oder nur teilweise überlappen.
Da stört schonmal bei der Umrechnung in Arbeitsstunden, dass 6:00 <
20:00 ist, also teile ich die Nachtschicht in 20:00 - 24:00 und 0:00 -
6:00. Also 4 + 6 = 10 Stunden.
Und hier gehts schon los: es gibt keine 24:00-Zeit in Excel, da gehts
nur bis 23:59:59.

Frage: ist mein Konzept schon vom Ansatz her falsch und wird das
gaaanz anders gemacht?
Zusatzfrage: Wenn ich eine Date-Variable tmpzeit = "23:00" habe, wie
addiere ich da Stunden oder Minuten drauf?

Danke für Wegweisungen
Jo

Hallo Jochen,

hier mal eine kleine Wegweisung:
XL rechnet nicht mit Zeiten sondern mit Zahlen, auch wenn es nicht so
aussieht.
Formatiere mal Deine Zellen mit der Datumsangabe als Zahl und Du wirst etwas
in der Art von 39689 sehen.
XL beginnt mit der Zeit- und Datumsberechnung am 01.01.1900, ist gleich (als
Zahl) 1.
Genau so wird die Zeit berechnet.
A1 = (als Zeit formatiert) 1:00:00
B1 = (als Zahl formatiert) Formel ¡/1440 (1440 ergibt sich aus 24 h * 60
min.) ergibt die Zahl 0,000028935.
In C1 die Formel ±*1440 und C1 als Zeit formatiert ergibt die Zeit 1:00.
Deine Formel zur Zeitberechnung mit Nachtstunden sollte also so aussehen,
z.B.:
In A2 steht die Kommt-Zeit und in B2 die Geht-Zeit, die Formel in C2:

=WENN(B2<A2;B2+1-A2;B2-A2)

Sollte eigentlich helfen (ansonsten "google" Zeitberechnung mit Excel)

MfG
Peter

Ähnliche fragen