Zeitwert als Dezimalzahl

01/05/2009 - 07:03 von Roland | Report spam
Guten Morgen und einen schönen 1ten Mai,
mit dieser Formel:
=WENN(A12="Sonntag";WENN(C12>E12;24-C12;E12-C12);WENN(UND(A12="Samstag";C12>E12);E12-G12;""))werden
mir in Zelle L12 die gearbeiteten Sonntagstunden ausgegeben, das klappt
auch wunderbar, die Zelle ist formatiert mit "hh:mm", nun möchte jemand,
der die Tabelle weiterbearbeitet keine Zeitwerte haben sondern
Dezimalzahlen, nichts leichter als das dachte ich. Hab mir eine
Hilfsspalte (K12) gemacht mit der Formel =SUMME(L12*24)und als Zahl
formatiert. das klappt auch, nur wenn ich Sonntags Arbeite bsp. von 17 -
5 Uhr wird mir in L12 richtigerweise 7:00 errechnet (von 17 Uhr - 0 Uhr
= 7 Stunden) aber in K12 559,00 anstatt 7,00 Das ist bei Excel 2003 und
auch 2007 so.

wo ist (m)ein Rechenfehler

Gruß und Danke
Roland
 

Lesen sie die antworten

#1 Eberhard Funke
01/05/2009 - 10:28 | Warnen spam
Am Fri, 01 May 2009 07:03:40 +0200 schrieb Roland:

Guten Morgen und einen schönen 1ten Mai,
mit dieser Formel:
=WENN(A12="Sonntag";WENN(C12>E12;24-C12;E12-C12);WENN(UND(A12="Samstag";C12>E12);E12-G12;""))werden
mir in Zelle L12 die gearbeiteten Sonntagstunden ausgegeben, das klappt
auch wunderbar, die Zelle ist formatiert mit "hh:mm", nun möchte jemand,
der die Tabelle weiterbearbeitet keine Zeitwerte haben sondern
Dezimalzahlen, nichts leichter als das dachte ich. Hab mir eine
Hilfsspalte (K12) gemacht mit der Formel =SUMME(L12*24)und als Zahl
formatiert. das klappt auch, nur wenn ich Sonntags Arbeite bsp. von 17 -
5 Uhr wird mir in L12 richtigerweise 7:00 errechnet (von 17 Uhr - 0 Uhr
= 7 Stunden) aber in K12 559,00 anstatt 7,00 Das ist bei Excel 2003 und
auch 2007 so.

wo ist (m)ein Rechenfehler




Hallo Roland,

wenn in L12 7:00 steht (und wenn - zur Kontrolle - L12 als Standard
formatiert 0,291666666666667 ergibt), dann sollte es gleichgültig sein, mit
welcher Formel die 7:00 in die Zelle L12 kommt.
Der m. E. einzig sichere Weg zu einer Diagnose ist der, dass Du die Tabelle
(bitte die XL2003 Version!) hochlàdst, z. B. mit
http://rapidshare.com/howto_upload.html
und den Link hier postest:

Übrigens, warum in K12: =SUMME(L12*24) statt =L12*24?

Mit freundlichen Grüssen Eberhard
XP home XL 2000
Eberhard(punkt)W(punkt)Funke(at)t-online.de

Ähnliche fragen