Zellen vergleichen und überschreiben

24/02/2008 - 18:03 von Jörg Klein | Report spam
Hallo,

ich habe eine Frage beim Vergleich von Zellen.

In einer Tabelle habe ich folgende Spalten:

A B C D
A1 120 24.02.2008 100 23.02.2008
Ausgangszustand

nun sollte die Zeile folgendermassen geàndert werden:
A1 120 24.02.2008 120 24.02.2008 gewünschtes
Ergebnis

In Zelle A1 steht eine Zahl, z.B. 120 und in Zelle B1 steht das aktuelle
Datum.
In Zelle C1 steht eine andere Zahl, z.B. 100 und in Zelle D1 steht das Datum
vom Vortag.

Nun möchte ich, wenn in Zelle A1 die Zahl größer als in Zelle C1 ist, dass
das Datum in D1 aktuallisert wird und die Zahl von Zelle A1 in die Zelle C1
geschrieben wird.

Ich hoffe, dass ich mich verstàndliche ausgedrückt habe.

Vielen Dank für die Hilfe Jörg
 

Lesen sie die antworten

#1 Andreas Stoye
24/02/2008 - 19:50 | Warnen spam
Hi Jörg,

Jörg Klein schrieb im Newsbeitrag
news:
Hallo,

ich habe eine Frage beim Vergleich von Zellen.

In einer Tabelle habe ich folgende Spalten:

A B C D
A1 120 24.02.2008 100 23.02.2008 Ausgangszustand

nun sollte die Zeile folgendermassen geàndert werden:
A1 120 24.02.2008 120 24.02.2008
gewünschtes Ergebnis

In Zelle A1 steht eine Zahl, z.B. 120 und in Zelle B1 steht das
aktuelle Datum.
In Zelle C1 steht eine andere Zahl, z.B. 100 und in Zelle D1 steht
das Datum vom Vortag.

Nun möchte ich, wenn in Zelle A1 die Zahl größer als in Zelle C1 ist,
dass das Datum in D1 aktuallisert wird und die Zahl von Zelle A1 in
die Zelle C1 geschrieben wird.

Ich hoffe, dass ich mich verstàndliche ausgedrückt habe.



Schàtze, dann hast du ein Problem mit Zirkelbezügen. Ohne Hilfsspalte
(und ohne VBA) wird es nicht gehen, z.B. in E und F stànde dann das
Ergebnis vom Vortag. In C1: =WENN(A1>E1;A1;E1) und D1 analog. E und F
gegebenenfalls ausblenden.

HTH Andreas Stoye

Ähnliche fragen