Zelleninhalt mit Spalte vergleichen geht nicht

06/10/2008 - 12:07 von larazza | Report spam
Hallo,

ich möchte eine Tabelle durchsuchen und einen Index ausgeben.
Das soll so aussehen:

Preisgruppe Auflage von Mengengruppe
1 0 1
1 43000 2
2 0 3
2 50000 4

Ich habe diese Funktion versucht, welche aber nicht wirklich funktioniert:

{=VERGLEICH(E2&D2;B1:B5&A1:A5;1)}

Wenn ich Preisgruppe 1 und 1000 eingebe, dann bekomme ich Mengengruppe 1.
Wenn ich aber Preisgruppe 1 und 5000 eingeben, erhalte ich Mengengruppe 2
als Ergebnis, obwohl Gruppe 1 von 0-42999 sein müsste.

Kann ich diese Funktion für den gewünschten Effekt nicht hernehmen?
Gibt es eine andere Lösung?
 

Lesen sie die antworten

#1 Claus Busch
06/10/2008 - 12:50 | Warnen spam
Hallo Larazza,

Am Mon, 6 Oct 2008 03:07:06 -0700 schrieb larazza:

Ich habe diese Funktion versucht, welche aber nicht wirklich funktioniert:

{=VERGLEICH(E2&D2;B1:B5&A1:A5;1)}



Vergleich liefert dir die Zeilenzahl in der der Suchwert gefunden wurde.
Probiers mal so:
=INDEX(C:C;VERGLEICH(D2&E2;A1:A5&B1:B5;1))
und mit STRG+Shift+Enter abschließen.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP3 / Vista Ultimate
Office 2003 SP3 / 2007 Ultimate SP1

Ähnliche fragen