Zieldatum berechnen

08/07/2013 - 21:44 von Peter | Report spam
Hallo,
ich brauche Hilfe bei einer Formel zur Berechnung eines Datums
Spalte A = Startdatum
Spalte B = Intervall
Spalte C = Zieldatum
A und B sind gegeben und C soll errechnet werden wobei
in Spalte B unterschiedliche Intervalle stehen
1W = 1 Woche
2W = 2 Wochen
1M = 1 Monat
3M = 3 Monate

Als Ergebnis in C soll z.B. bei
02.01.2013 - 1W - 09.01.2013
15.02.2013 - 1M - 15.03.2013
also immer einen Monat hinzu und nicht 30 Tage
und bei 3M eben
15.02.2013 - 3M - 15.05.2013

Wie mache ich das mit einer Formel in Spalte C
die mir den Intervall aus Spalte B ausliest und
das Zieldatum errechnet ?

mfg
Peter
 

Lesen sie die antworten

#1 Claus Busch
08/07/2013 - 21:58 | Warnen spam
Hallo Peter,

Am Mon, 08 Jul 2013 21:44:39 +0200 schrieb Peter:

Spalte A = Startdatum
Spalte B = Intervall
Spalte C = Zieldatum



probiere es in C1 mit:
=WENN(RECHTS(B1;1)="W";A1+LINKS(B1;LÄNGE(B1)-1)*7;DATUM(JAHR(A1);MONAT(A1)+LINKS(B1;LÄNGE(B1)-1);TAG(A1)))


Mit freundlichen Grüßen
Claus
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen